The default bug view has changed. See this FAQ.

incorrect hypothetical box right with asymmetric containing block border

RESOLVED FIXED in mozilla1.9beta4

Status

()

Core
Layout: R & A Pos
RESOLVED FIXED
9 years ago
9 years ago

People

(Reporter: dbaron, Assigned: dbaron)

Tracking

({regression})

Trunk
mozilla1.9beta4
regression
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Assignee)

Description

9 years ago
Created attachment 305051 [details] [diff] [review]
patch

I caught this while writing a reftest for bug 403328.  That bug actually regresses some cases due to this bug because it switches when we use mLeft vs mRight, so I want to land this at the same time.

In any case, nsHTMLReflowState::CalculateHypotheticalBox does the wrong thing when adjusting for the border of the absolute positioning containing block.  mRight is relative to the left edge, so it should adjust it by the left border, but instead it adjusts it by the right border.

This will be tested in my reftest for bug 403328.
Attachment #305051 - Flags: superreview?(roc)
Attachment #305051 - Flags: review?(roc)
> I caught this while writing a reftest for bug 403328.  That bug actually
> regresses some cases due to this bug because it switches when we use mLeft vs
> mRight, so I want to land this at the same time.

Not sure whether you noticed - I landed 403328 a few hours ago (with a reftest based on my testcase for that bug).
(Assignee)

Comment 2

9 years ago
(I landed the reftests in question as layout/reftests/box-properties/abspos-* .)
(Assignee)

Comment 3

9 years ago
Created attachment 305373 [details] [diff] [review]
patch

Same as previous, plus changes to reftest.list.
Attachment #305051 - Attachment is obsolete: true
Attachment #305373 - Flags: superreview?(roc)
Attachment #305373 - Flags: review?(roc)
Attachment #305051 - Flags: superreview?(roc)
Attachment #305051 - Flags: review?(roc)
(Assignee)

Comment 4

9 years ago
This mistake was introduced in the patch on bug 135082.
Blocks: 135082
(Assignee)

Updated

9 years ago
Keywords: regression
Attachment #305373 - Flags: superreview?(roc)
Attachment #305373 - Flags: superreview+
Attachment #305373 - Flags: review?(roc)
Attachment #305373 - Flags: review+
(Assignee)

Comment 5

9 years ago
Comment on attachment 305373 [details] [diff] [review]
patch

Low risk change to fix position used for some absolute positioning cases (most common in RTL documents) where the containing block has asymmetric borders.
Attachment #305373 - Flags: approval1.9?
Comment on attachment 305373 [details] [diff] [review]
patch

a1.9+=damons
Attachment #305373 - Flags: approval1.9? → approval1.9+
(Assignee)

Comment 7

9 years ago
Checked in to trunk.
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.