Form elements (text fields, submit buttons) use page-defined colors when "allow pages to choose their own colors" is unticked.

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
11 years ago
10 years ago

People

(Reporter: sjh-bugzilla, Unassigned)

Tracking

({regression, testcase})

Trunk
x86
Windows XP
regression, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(7 attachments)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b3) Gecko/2008020514 Firefox/3.0b3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b3) Gecko/2008020514 Firefox/3.0b3

This bug was not present in 3.0alpha build from 2007-05-15 and then appeared in the 2007-05-16 and subsequent builds.

When using a user-defined colour scheme, some text entry fields don't adopt the border colour as expected.  Refer to attachments for visual demonstration.



Reproducible: Always

Steps to Reproduce:
1. Configure Windows colour scheme to high contrast with a black background.
2. Configure Firefox colours (options -> content -> colors) to use system colours and untick "Allow pages to use their own colours..."
3. Go to www.facebook.com
Actual Results:  
Some text fields (www.facebook.com - www.youtube.com for example) don't have visible borders, or the borders are not coloured as per user-defined colour scheme.

See attachment for screenshot.

Expected Results:  
All text fields should use the border colour as defined by the users colour scheme.

See screenshot attachment for example.
(Reporter)

Comment 1

11 years ago
Created attachment 305120 [details]
Screenshot of 3.0a5pre (20070515 build) - page rendered correctly, bug not visible
(Reporter)

Comment 2

11 years ago
Created attachment 305121 [details]
Screenshot of 3.0a5pre (20070516 build) - bug visible as of this build

The text-field border colouring bug is now present in this screenshot.  The 2007-05-15 nightly build did not have the issue, all nightly builds from this point onwards DO have the bug.
(Reporter)

Updated

11 years ago
Component: General → Widget: Win32
Keywords: regression
Product: Firefox → Core
Version: unspecified → Trunk
(Reporter)

Comment 3

11 years ago
Created attachment 305271 [details]
testcase to use with steps to reproduce
(Reporter)

Updated

11 years ago
Component: Widget: Win32 → Layout
Keywords: testcase
Summary: Some text entry fields don't adopt border color of user-defined colour scheme → Form elements (text fields, submit buttons) use page-defined colors when "allow pages to choose their own colors" is unticked.
QA Contact: general → layout
Created attachment 307714 [details]
image of Testcase 2 when we untick "Allow websites to set their own colours" 

Using two builds:
- 20070516_1345_firefox-3.0a5pre.en-US.win32
- 20070517_0247_firefox-3.0a5pre.en-US.win32

With a new profile, and after going into Tools > Options > Content > Colours and unticking "Allow web pages to choose their own colours". We can see the rendering of Testcase 2 has changed.

Checkins to module PhoenixTinderbox between 2007-05-16 13:45 and 2007-05-17 02:47 : 

http://bonsai.mozilla.org/cvsquery.cgi?treeid=default&module=PhoenixTinderbox&branch=HEAD&branchtype=match&dir=&file=&filetype=match&who=&whotype=match&sortby=Date&hours=2&date=explicit&mindate=2007-05-16+13%3A45&maxdate=2007-05-17+02%3A47&cvsroot=%2Fcvsroot

Probably due to bug 58048 I'd guess.
Created attachment 307718 [details]
Image of Testcase 2 with custom colours. text=white, background=black

In Tools > Options > Content > Colours, we now have
- untick "Allow web pages to choose their own colours"
- Text = White
- Background = Black

With 20070516_1345 things are obeying our preferences. But with 20070517_0247 the form elements still have system-styling on, and the text box uses black text and a white background - the opposite of what we have specified in the Firefox UI.
Created attachment 307719 [details]
Image of Testcase 2 with custom colours. text=white, background=black, high contrast OS theme

In Tools > Options > Content > Colours, we still have
- untick "Allow web pages to choose their own colours"
- Text = White
- Background = Black

but now the OS theme has changed from Windows Classic to High Contrast Black. Note we've not lost the border round the text boxes (so it's not apparent you can type anything there) and we have also lost the border around the buttons (so it's not obvious they're clickable).

This is a change when compared to Firefox 2. But I don't know if the change is expected and/or wanted, so I can't confirm this as a bug atm.
What should be happening is that we're drawing native-looking form controls.  Do the native-looking form controls not have any border?
Is this still an issue?
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b3pre) Gecko/20090213 Shiretoko/3.1b3pre ID:20090213033101
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2a1pre) Gecko/20090213 Minefield/3.2a1pre

You know what, I don't think it is. When using the High Contrast Black windows theme and changing Tools > Options > Content > Colours to:
- untick "Allow web pages to choose their own colours"
- Text = White
- Background = Black

Testcase 2 now shows outlines for the text boxes and for the buttons too.

Steve Horan, could you confirm this with a nightly trunk build? Thanks!
- http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-mozilla-central/
(Reporter)

Comment 11

10 years ago
Hi,

Yes, it appears to have been resolved. I tested with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2a1pre) Gecko/20090213 Minefield/3.2a1pre and form elements now all have borders as expected.
Steve, Steve, thanks for retesting!

Resolving per those comments.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.