Closed Bug 419181 Opened 12 years ago Closed 12 years ago

Oversized user interface after switching to widescreen monitor

Categories

(Firefox :: General, defect, major)

x86
Linux
defect
Not set
major

Tracking

()

RESOLVED DUPLICATE of bug 394103

People

(Reporter: forseti, Unassigned)

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.8) Gecko/20071101 Firefox/2.0.0.8 Flock/1.0
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.8) Gecko/20071101 Firefox/2.0.0.8 Flock/1.0

After I switched from using normal LCD flat screen to wodescreen one the whole Firefox UI became oversized. While text size in menus and tabs haven't changed, all the icons, graphics like favicons, close tab buttons etc. become magnified and seem to push the limits of their toolbars and tabs. Also, the content of web page is magnified. Enabling safe mode doesn't rectify the problem.

Reproducible: Always

Steps to Reproduce:
1. Just run the firefox start file

Actual Results:  
See attached screenshot showing the comparison between affected Minefield build of Firefox and unaffected Flock instance. The widescreen resolution is 1366*768.

Expected Results:  
Obviously, UI shouldn't be THAT big :)
The Build Identifier of affected Firefox build is:
Mozilla/5.0 (X11; U; Linux i686; pl; rv:1.9b3) Gecko/2008020513 Firefox/3.0b3

Sorry for my mistake, I was posting this from Flock since Firefox is unusable.
might be bug 394103

can you try if setting explicitly layout.css.dpi in about:config solves this? (for instance, to 96)
Yes, it helps. After changing it everything returns back to normal size. Factory default for this key is -1, however. Perhaps it needs more sane default or better logic to detect the change in screen geometry.

Thanks for help anyway :)
Status: UNCONFIRMED → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 394103
You need to log in before you can comment on or make changes to this bug.