bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

"msgHeaderParser is not defined" when dragging mail to Calendar item

VERIFIED FIXED in 0.9

Status

Calendar
Lightning Only
VERIFIED FIXED
11 years ago
10 years ago

People

(Reporter: Henrik Gemal, Assigned: ssitter)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

11 years ago
when I drag a mail to Calendar item I get:

Error: msgHeaderParser is not defined
Source File: chrome://calendar/content/calendar-dnd-listener.js
Line: 62

using trunk tbird and trunk lightning

Comment 1

11 years ago
Henrik, does this also happen with branch builds?

And what build were you using (TB and LT)?
(Reporter)

Comment 2

11 years ago
TB: version 3.0a1pre (2008022103)
Lightning: 0.6a1 (2008022218)
(Assignee)

Comment 3

11 years ago
Works for me using Thunderbird 2.0.0.13pre (20080222) + Lightning 0.8pre (2008022218) but I can confirm for Trunk builds.

This seems to be caused by Bug 416666 that removed msgHeaderParser from global scope in mail/base/content/msgHdrViewOverlay.js.
Blocks: 416666
Version: unspecified → Trunk
(Assignee)

Comment 4

11 years ago
Created attachment 305206 [details] [diff] [review]
don't rely on global var msgHeaderParser

This patch ought to work for trunk (by getting the service directly) and mozilla1.8 branch (by renaming msgHeaderParser to headerParser).
Assignee: nobody → ssitter
Status: NEW → ASSIGNED
Attachment #305206 - Flags: review?(daniel.boelzle)

Comment 5

11 years ago
Comment on attachment 305206 [details] [diff] [review]
don't rely on global var msgHeaderParser

r=dbo
Attachment #305206 - Flags: review?(daniel.boelzle) → review+
(Assignee)

Updated

11 years ago
Keywords: checkin-needed
Whiteboard: [checkin needed after 0.8]
Checked in on HEAD and MOZILLA_1_8_BRANCH

-> FIXED
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Keywords: checkin-needed
OS: Windows XP → All
Hardware: PC → All
Resolution: --- → FIXED
Whiteboard: [checkin needed after 0.8]
Target Milestone: --- → 0.9

Comment 7

10 years ago
Checked with nightly trunk build 2008041318 -> task is verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.