Too much RAM memory usage if I open 5 to 10 tabs

RESOLVED INVALID

Status

()

Firefox
Tabbed Browser
RESOLVED INVALID
10 years ago
10 years ago

People

(Reporter: Iulian Donici, Unassigned)

Tracking

2.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.12) Gecko/20080201 Firefox/2.0.0.12
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.12) Gecko/20080201 Firefox/2.0.0.12

As you can see in my printscreen, I only opened 7 tabs, a few blogs, google and gmail...and Firefox already consumes me a little over 100,000K. I've only got 512RAM and what should that supposed to mean? If I open let's say 15 tabs I'll just have to plug in some more RAM into my computer just for Firefox? Come on, I'm promoting you all the time to my friends, customers, the best alternative for IE and I was even going to buy myself a few items with Firefox logo... What's going on guys? That's the only thing that bothers me at Firefox. I'm using it a lot, I do lots of web reading and I don't even open pages that require JRE most of the times. Please, do something about this ram memory issue. I know these sutff can't be accurate, these bug reports, some pages can have some extra content such as an Youtube movie or a Java application, in fact only the ZOSO's Blog tab has one Youtube movie. But come on, it's still too much. You guys, do something about it and I assure I'm not the only one to whom this has happened.

Reproducible: Always

Steps to Reproduce:
1. I open 2-3 tabs, ok.
2. I open more than 5 tabs, Firefox consumes over 100,000k.

Actual Results:  
Sometimes Firefox gets stuck if I have more than 5 tabs opened (with pages loaded). Probably just because of this too much ram memory use. 

Expected Results:  
It should've consumed me at most 50,000ks/7 tabs let's say. 

I'm using the default theme. I don't even have bookmarks. It's all fresh and clean. The only changes I did to my Firefox were the 2 homepage tabs: my blog and Google + set Firefox as default browser and my own location for any downloads. One of your mottos is 'Faster surfing'. Does that come with the price of more RAM?
(Reporter)

Comment 1

10 years ago
Well, hope the next firefox update would fix this problem. 
Keywords: dataloss
Version: unspecified → 2.0 Branch
There's nothing wrong with 7 tabs using 100MB. This bug is neither 'major' nor 'dataloss', and in fact is too vague for anyone to do anything about it, so I'm resolving it INVALID.

Firefox 3 has had a lot of work done to it wrt memory usage. Perhaps this may help you.
Severity: major → normal
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Keywords: dataloss
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.