get_new_status_and_resolution() no longer exists and bug moving fails

RESOLVED FIXED in Bugzilla 3.2

Status

()

--
blocker
RESOLVED FIXED
11 years ago
11 years ago

People

(Reporter: guy.pyrzak, Assigned: LpSolit)

Tracking

({regression})

3.1.2
Bugzilla 3.2
regression
Dependency tree / graph
Bug Flags:
approval +
blocking3.2 +

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

11 years ago
Try to move a bug to another install using the landfill. You will run into this bug.

In process bug, line 438:        my ($status, $resolution) = $bug->get_new_status_and_resolution('move');
Flags: blocking3.2?
(Assignee)

Updated

11 years ago
Flags: blocking3.2? → blocking3.2+
Keywords: regression
OS: Mac OS X → All
Hardware: PC → All
Target Milestone: --- → Bugzilla 3.2
(Assignee)

Comment 1

11 years ago
Regression due to bug 402791.
Depends on: 402791
(Assignee)

Updated

11 years ago
Assignee: create-and-change → LpSolit
(Assignee)

Comment 2

11 years ago
Created attachment 305544 [details] [diff] [review]
patch, v1
Attachment #305544 - Flags: review?(mkanat)
(Assignee)

Updated

11 years ago
Status: NEW → ASSIGNED
Summary: get_new_status_and_resolution is missing from Bug.pm → get_new_status_and_resolution() no longer exists and bug moving fails

Comment 3

11 years ago
Comment on attachment 305544 [details] [diff] [review]
patch, v1

I'm not totally happy with adding $moving, but I suppose I see why it's there.

Now that we have so many parameters to set_status and set_resolution, they need to be named parameters after the first one. For example, set_status needs to be:

set_status($status, { resolution => $resolution, dupe_of => $dupe_of, moving => 1 });
Attachment #305544 - Flags: review?(mkanat) → review-
(Assignee)

Comment 4

11 years ago
Created attachment 305619 [details] [diff] [review]
patch, v2
Attachment #305544 - Attachment is obsolete: true
Attachment #305619 - Flags: review?(mkanat)

Comment 5

11 years ago
Comment on attachment 305619 [details] [diff] [review]
patch, v2

Okay, looks good to me.
Attachment #305619 - Flags: review?(mkanat) → review+

Updated

11 years ago
Flags: approval+
(Assignee)

Comment 6

11 years ago
Checking in process_bug.cgi;
/cvsroot/mozilla/webtools/bugzilla/process_bug.cgi,v  <--  process_bug.cgi
new revision: 1.407; previous revision: 1.406
done
Checking in Bugzilla/Bug.pm;
/cvsroot/mozilla/webtools/bugzilla/Bugzilla/Bug.pm,v  <--  Bug.pm
new revision: 1.235; previous revision: 1.234
done
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
(Reporter)

Updated

11 years ago
Blocks: 414236
(Assignee)

Updated

11 years ago
Blocks: 431730
You need to log in before you can comment on or make changes to this bug.