AUS updates a localized Linux SeaMonkey version to en-US

RESOLVED WORKSFORME

Status

defect
RESOLVED WORKSFORME
11 years ago
4 years ago

People

(Reporter: adriank, Assigned: kairo)

Tracking

Trunk
All
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; PL; rv:1.8.1.12) Gecko/20080201 MultiZilla/1.8.3.4e SeaMonkey/1.1.8
Build Identifier: 

After an automatic update of a localized SeaMonkey version, SeaMonkey switches to en-US.
It looks like the update URL maybe points to the en-US Version, because after trying to update the Polish version I tried the same with German and French versions, where the update was downloaded in one second. 

Reproducible: Always

Steps to Reproduce:
1. Download a yesterdays localized Linux SeaMonkey build
2. Do an automatic update
3. See SeaMonkey in english
(Reporter)

Updated

11 years ago
Version: unspecified → Trunk
(Reporter)

Updated

11 years ago
OS: All → Linux
(Assignee)

Comment 1

11 years ago
https://aus2-community.mozilla.org/update/1/SeaMonkey/2.0a1pre/2008022401/Linux_x86-gcc3/pl/nightly/update.xml seems to offer the correct build, so we might really sending the wrong update URL - this should have the running locale though, see http://mxr.mozilla.org/seamonkey/source/suite/browser/browser-prefs.js#251
Assignee: general → kairo
(Assignee)

Comment 2

11 years ago
What is general.useragent.locale set to in a build that updates to the wrong languge?
(Assignee)

Comment 3

11 years ago
Hmm, this works fine for me with a German Linux build.

Could you set app.update.log.Checker pref to true via about:config, restart SeaMonkey and tell which URL is being called (will be logged in error console)?
(Reporter)

Comment 4

11 years ago
ok, I investigated a little bit. The problem happens to me on two profiles which were created some (long) time ago with an en-US Version of SeaMonkey nightlies.
general.useragent.locale is set there to en-US. Starting SeaMonkey in an another language does not change general.useragent.locale . After changing that pref manually, updating works correctly. 
Unfortunately (or not ;) ), I couldn't reproduce that bug on a new profile (no matter if created using en-US or pl SeaMonkey), so maybe it was introduced by an old nightly and is gone by now. 

If I'll find a way to reproduce that bug on a new profile, I'll reopen that bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME

Updated

4 years ago
See Also: → 1228572
You need to log in before you can comment on or make changes to this bug.