"CSS3 Selector Testsuite" fails for different selectors

RESOLVED DUPLICATE of bug 128585

Status

()

Core
CSS Parsing and Computation
RESOLVED DUPLICATE of bug 128585
10 years ago
10 years ago

People

(Reporter: Márton Németh, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; hu; rv:1.9b3) Gecko/2008020513 Firefox/3.0b3
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; hu; rv:1.9b3) Gecko/2008020513 Firefox/3.0b3

At the "CSS3 Selector Testsuite" the following test cases fails:
    * :first-child(1 out of 7 failed)
    * :last-child(1 out of 7 failed)
    * :only-child(1 out of 5 failed)
    * :nth-child()(47 out of 88 failed)
    * :nth-last-child()(47 out of 88 failed)
    * :first-of-type(7 out of 10 failed)
    * :last-of-type(7 out of 10 failed)
    * :only-of-type(3 out of 5 failed)
    * :nth-of-type()(47 out of 88 failed)
    * :nth-last-of-type()(47 out of 88 failed)
    * :empty(1 out of 6 failed)


Reproducible: Always

Steps to Reproduce:
1. Open and run the testsuite by visiting page http://www.css3.info/selectors-test/test.html

Actual Results:  
From the 43 selectors 32 have passed, 4 are buggy and 7 are unsupported (Passed 369 out of 578 tests)

Expected Results:  
From the 43 selectors 43 have passed, 0 are buggy and 0 are unsupported (Passed 369 out of 369 tests)
Component: General → Style System (CSS)
Product: Firefox → Core
QA Contact: general → style-system
(Reporter)

Comment 1

10 years ago
The test results are:

From the 43 selectors 36 have passed, 0 are buggy and 7 are unsupported (Passed 374 out of 579 tests)

with version: Mozilla/5.0 (X11; U; Linux i686; hu; rv:1.9b4pre) Gecko/2008022904 Minefield/3.0b4pre

The problem ones are:
 * :nth-child()(47 out of 88 failed)
 * :nth-last-child()(47 out of 88 failed)
 * :first-of-type(7 out of 10 failed)
 * :last-of-type(7 out of 10 failed)
 * :only-of-type(3 out of 5 failed)
 * :nth-of-type()(47 out of 88 failed)
 * :nth-last-of-type()(47 out of 88 failed)

Comment 2

10 years ago
exactly the same results as comment#1 on Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b5pre) Gecko/2008030604 Minefield/3.0b5pre)

useful urls:
http://www.css3.info/selectors-test/test-nthchild.html#nthchild
http://www.css3.info/selectors-test/test-nthlastchild.html#nthlastchild
http://www.css3.info/selectors-test/test-firsttype.html#firsttype
http://www.css3.info/selectors-test/test-lasttype.html#lasttype
http://www.css3.info/selectors-test/test-onlytype.html#onlytype
http://www.css3.info/selectors-test/test-nthtype.html#nthtype
http://www.css3.info/selectors-test/test-nthlasttype.html#nthlasttype
these will save time running the long test

quick summary of results, stuff in brackets occurred in some explanations but not all.

nth-child: the css selector should match the marked element because,...
it is the first (and only child) of the outer div element
every element (starting from the second) should match 
*should match the div element that is inserted by the Javascript code. 


nth-last-child: the css selector should match the marked element because,...
it is the last (and only child) of the outer div element
it is the second child from the bottom of the outer div element 
every element (before the second from the bottom should) should match
every even/odd element counting from the bottom should match 
every third element should match counting from the first from bottom 
the last two elements should match
*should match the div element that is inserted by the Javascript code.

first/last-of-type: The CSS selector should match the marked div element, because...
it is the only element of this type 
it is the first element of this type (in this scope) (in this current scope)
*

last-of-type: The CSS selector should match the marked div element, because...
it is the only element of this type
it is the first element of this type (in this scope) (in this current scope)
*

only-of-type: The CSS selector should match the marked div element, because it is the only element of this type ( in this scope )

nth-of-type:  The CSS selector should match the marked element, because...
It is the first/second (and only) child of the correct type 
every (even/odd) element of the correct (starting from the second) type should match
*

nth-last-of-type: The CSS selector should match the marked element, because...
it is the last (and only) child of the correct type 
it is the second child from the bottom of the correct type 
every element (before the second) of the correct type should match
every even/odd element of the correct type counting from the bottom should match.
*

sorry if this is useless/unreadable i tried stripping it down to the bear minimum even if it meant that the should be all in some cases. (* represents a javascript error (but as the rest of the test was failed i doubt it matters) The original in context descriptions are on the linked pages (not all errors are at the top of the page).
We know what those selectors are, we know that we haven't implemented them, and it's on my list of things to do after Firefox 3 ships.

Comment 4

10 years ago
(In reply to comment #2)
> exactly the same results as comment#1 on Mozilla/5.0 (X11; U; Linux i686;
> en-US; rv:1.9b5pre) Gecko/2008030604 Minefield/3.0b5pre)
> nth-child: the css selector should match the marked element because,...
> it is the first (and only child) of the outer div element
> every element (starting from the second) should match 
> *should match the div element that is inserted by the Javascript code. 
bug 75375
> 

> nth-last-child: the css selector should match the marked element because,...
> it is the last (and only child) of the outer div element
> it is the second child from the bottom of the outer div element 
> every element (before the second from the bottom should) should match
> every even/odd element counting from the bottom should match 
> every third element should match counting from the first from bottom 
> the last two elements should match
> *should match the div element that is inserted by the Javascript code.
bug 75375

> 
> first/last-of-type: The CSS selector should match the marked div element,
> because...
bug 128585
> 
> last-of-type: The CSS selector should match the marked div element, because...
> it is the only element of this type
> it is the first element of this type (in this scope) (in this current scope)
bug 128585
 
> only-of-type: The CSS selector should match the marked div element, because it
> is the only element of this type ( in this scope )
bug 128585 

> nth-of-type:  The CSS selector should match the marked element, because...
> It is the first/second (and only) child of the correct type 
> every (even/odd) element of the correct (starting from the second) type should
> match
bug 75375

> 
> nth-last-of-type: The CSS selector should match the marked element, because...
> it is the last (and only) child of the correct type 
> it is the second child from the bottom of the correct type 
> every element (before the second) of the correct type should match
> every even/odd element of the correct type counting from the bottom should
> match.
> *
bug 75375

So, it looks like this is covered by several other bugs.

I'm going to mark it as a dupe.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 128585
You need to log in before you can comment on or make changes to this bug.