W3C CSS3 Selector test fails: Multiple IDs (ID #15c)

RESOLVED DUPLICATE of bug 275196

Status

()

RESOLVED DUPLICATE of bug 275196
11 years ago
10 years ago

People

(Reporter: nm127, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; hu; rv:1.9b3) Gecko/2008020513 Firefox/3.0b3
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; hu; rv:1.9b3) Gecko/2008020513 Firefox/3.0b3

The first line "This line should be green" is red at test case http://www.w3.org/Style/CSS/Test/CSS3/Selectors/current/xhtml/full/flat/css3-modsel-15c.xml


Reproducible: Always

Steps to Reproduce:
1. visit http://www.w3.org/Style/CSS/Test/CSS3/Selectors/current/xhtml/full/flat/css3-modsel-15c.xml
(Reporter)

Comment 1

11 years ago
Created attachment 305320 [details]
screenshot with red text on Linux

The screenshot was made with:
Mozilla/5.0 (X11; U; Linux i686; hu; rv:1.9b3) Gecko/2008020513 Firefox/3.0b3
Component: General → Style System (CSS)
Product: Firefox → Core
QA Contact: general → style-system
This isn't a style system bug, really.  The test says it requires support for two or more of things that we support only one of -- though we had a patch for xml:id.
(I guess the part of it that is a style system bug is fixed by the xml:id patch, which was reverted due to performance regressions.)

Comment 4

11 years ago
(In reply to comment #2)
> This isn't a style system bug, really.  The test says it requires support for
> two or more of things that we support only one of -- though we had a patch for
> xml:id.
David, where should it be filed then? 

xml:id is bug 275196.

setIdAttribute is bug 28851.

Marking duplicate of one of them, chosen sorta at random.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 275196
Er, I meant bug 288513 for setIdAttribute.
You need to log in before you can comment on or make changes to this bug.