See all results link in Get Add-Ons Prefs leads to invalid url if search contains spaces

RESOLVED DUPLICATE of bug 414595

Status

()

Toolkit
Add-ons Manager
RESOLVED DUPLICATE of bug 414595
10 years ago
10 years ago

People

(Reporter: Adam Dempsey, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.8.1.12) Gecko/20080201 Firefox/2.0.0.12
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b3) Gecko/2008020514 Firefox/3.0b3

If you search for an addon with a space in for example 'Web Developer' the 'See all results' links leads to

https://addons.mozilla.org/en-US/firefox/search?q=Web%2520Developer

instead of 

https://addons.mozilla.org/en-US/firefox/search?q=Web+Developer

The url is being escaped, but the website then doesn't support the unescaped space character, so either the website needs to support the way the add-ons sends the link or the url needs to not be escaped I guess.

Reproducible: Always

Steps to Reproduce:
1.  Tools --> Add-Ons
2.  Search for something with a space eg Web Developer
3.  Click the 'See all results' link
4.  https://addons.mozilla.org/en-US/firefox/search?q=Web%2520Developer opens but it needs to be blah/search?q=Web+Developer
Actual Results:  
Wrong url opens.

Expected Results:  
Either opened https://addons.mozilla.org/en-US/firefox/search?q=Web+Developer or the website allow for the url to be encoded.
Component: Preferences → Extension/Theme Manager
OS: Windows XP → All
QA Contact: preferences → extension.manager
Hardware: PC → All
Version: unspecified → Trunk

Updated

10 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 414595
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.