Closed Bug 419494 Opened 14 years ago Closed 14 years ago

Master Password prompt presented multiple times upon session restore

Categories

(Toolkit :: Password Manager, defect)

x86
macOS
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 348997

People

(Reporter: breckard, Unassigned)

Details

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9b4pre) Gecko/2008022504 Minefield/3.0b4pre

I currently have the Master Password enabled on my MBP.  When I restore my session, the Dialogue asking me to enter my Master Password is presented twice after each restore.  I have two tabs open that contain saved passwords, the first is to my Zimbra account and the second is set to access corporate intranet (through LDAP).  It appears the different passwords, LDAP vs. something else, aren't unified under the Master Password function on Mac OSX (Leopard and Tiger).

To Reproduce:
1) Set Master Password on your Mac
2) Start New Instance of FFx
3) Log into site requiring LDAP authentication
4) Check option to remember password
5) Open New Tab
6) Log into a new non LDAP protected site, Zimbra.com
7) Check option to remember password
8) Quit out of Browser instance
9) Restore Session

Result: Two separate dialogues requesting a Master Password are presented, one on top of the other.  

Note: FFx 2.0 unifies these dialogues so only one Master Password dialogue is presented.
Status: NEW → RESOLVED
Closed: 14 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 348997
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.