IE does not show pictures in files with Cyrilliс name saved in Firefox

NEW
Unassigned

Status

()

--
major
11 years ago
7 months ago

People

(Reporter: tim_tim2000, Unassigned)

Tracking

({parity-ie, parity-opera})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; ru; rv:1.8.1.12) Gecko/20080201 Firefox/2.0.0.12
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b4pre) Gecko/2008022404 Minefield/3.0b4pre

This is a regression from bug #409796 which was fixed on 24 February, 2008.

Reproducible: Always

Steps to Reproduce:
1. Save a webpage in a file with cyrillic filename.
2. Open the webpage in IE (I used 6.0 shipped with Windows XP SP2).
3. Open the webpage in Firefox 2 or trunk (I used Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b4pre) Gecko/2008022404 Minefield/3.0b4pre and Mozilla/5.0 (Windows; U; Windows NT 5.1; ru; rv:1.8.1.12) Gecko/20080201 Firefox/2.0.0.12). 

Actual Results:  
No pictures are shown or styles are applied in IE, but they do in Firefox 2 and 3.

Expected Results:  
Pictures shown and styles applied in both IE and Firefox.
(Reporter)

Comment 1

11 years ago
Adding dependency
Blocks: 409796
Keywords: regression
Whiteboard: [parity-IE]
Version: unspecified → Trunk

Comment 2

11 years ago
I have an idea how to fix it.
As I understand http://www.w3.org/TR/html401/charset.html
Everything in the .html should be encoded in the charset specified in the meta tag, am I right?
For example, if we have charset=win-1251, should all the text in the .html be encoded in win-1251 (including attributes of the src=). And escaped links? At this moment we write directory name in escaped utf8.
If we change utf8 to any charset we have to change the open routines (becouse by default it uses path in utf8). If we have win-1251 string in src="" it will be concatenated with full path in utf8.
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
OS: Windows XP → All

Updated

11 years ago
Severity: normal → major
Whiteboard: [parity-IE] → [parity-IE], [parity-Opera]

Updated

11 years ago
Assignee: nobody → lolkaantimat
Status: ASSIGNED → NEW
Hardware: PC → All
current firefox always encodes file URIs in UTF-8. anything else is lossy.


So I see two options, WONTFIX this bug or generate ASCII names for the files we save

Comment 4

11 years ago
(In reply to comment #3)
> current firefox always encodes file URIs in UTF-8. anything else is lossy.
Is it just internal representation of URIs? I guess yes, because there are a lot of non-UTF-8 pages with Cyrillic links. When we open the page we may convert the links from the charset specified in the meta to UTF-8, and when write - from UTF-8 to the page's charset.
I was only referring to file: URIs. For HTTP we do this differently.

Comment 6

11 years ago
The link from biezi: https://bugzilla.mozilla.org/show_bug.cgi?id=278161
Converting the names to ASCII may be a bad idea for webdevelopers (but good for users). If links are converted some people will have problems. It's more convenient to force everybody to use FF instead of IE and Opera.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 7

11 years ago
I doin't think it is possible to make 70% of people use Firefox, since most of them don't know what it is.
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---

Comment 8

11 years ago
I've tested ff b3 (without patch from 409796) and got the same. Since it isn't a regression I have changed the description of this bug. Also I'm not able to play with it right now, so reassign to nobody.
Assignee: lolkaantimat → nobody
No longer blocks: 409796
Status: REOPENED → NEW
Keywords: regression
Blocks: 409796
Keywords: regression
(In reply to comment #7)
> I doin't think it is possible to make 70% of people use Firefox, since most of
> them don't know what it is.

But to see the bug you need to save the page with Firefox first...

Comment 10

11 years ago
Numeric character references may solve the problem with utf-8 pages. But I don't think it may solve the problem with cp-1251 and another pages encoded in non-UTF-8. Tests are required. As proxyvictim told testcases are required too.
why wouldn't they solve the problem with non-utf8 pages?
(Reporter)

Comment 12

11 years ago
As the author of this bug, I'd like to confess initial addition of regression keyword as a mistake of mine. In fact, this is not a regression from bug #409796.
This exsisted long before the latter was fixed.
No longer blocks: 409796
Keywords: regression

Comment 13

11 years ago
(In reply to comment #11)
> why wouldn't they solve the problem with non-utf8 pages?

As I saw IE uses page settings to encode links. And also I have found that ff can't open win-1251 pages saved with IE.
I will create some testcases (attach html files and diffs) a bit later (maybe tomorrow).
 

Comment 14

11 years ago
Firefox 3 himself does not show pictures in files with Cyrilliс name saved in Firefox

My UA is "Mozilla/5.0 (Windows; U; Windows NT 5.1; ru; rv:1.9) Gecko/2008052906 Firefox/3.0"

URL is "http://forum.mozilla-russia.org/viewtopic.php?id=24037"

Saving name is "Кириллица" ("Cyrilliс" in Russian)
(Reporter)

Comment 15

11 years ago
ru-vadik,

This bug is not about Firefox 3, it is about IE.
Second, what program did you save your Кириллица.html with?
Anyway, Firefox 3 does show all the pictures.

Comment 16

11 years ago
Timur Timirkhanov,

I'm saved page with Firefox 3

Я сохранил страничку в Firefox 3 и им же потом открыл ее. Пути к рисункам и стилям оказались искаженными и Firefox 3 их не загрузил.

Comment 17

9 years ago
Please
Do it so as K-Meleon  or  give parameter saved in options
because latinian name of file  is chinese fo me and i whont have posible open saved file with IE on anothe computer
Иф ит диффикулт рид фо ю (If it difficult read for you), may be you undestend whith problem

Updated

3 years ago
Component: File Handling → File Handling
Product: Core → Firefox
Version: Trunk → unspecified
Mass bug change to replace various 'parity' whiteboard flags with the new canonical keywords. (See bug 1443764 comment 13.)
Keywords: parity-ie, parity-opera
Whiteboard: [parity-IE], [parity-Opera]
You need to log in before you can comment on or make changes to this bug.