[ActiveX] Implement window.external

RESOLVED INVALID

Status

Core Graveyard
Embedding: ActiveX Wrapper
--
enhancement
RESOLVED INVALID
10 years ago
6 years ago

People

(Reporter: Norman Rasmussen, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-ZA; rv:1.8.1.12; .NET CLR 2.0.50727) Gecko/20080201 Firefox/2.0.0.12
Build Identifier: 

IDocHostUIHandler.GetExternal returns an IDispatch object which should be available to the js environment as window.external.

Reproducible: Always




Related to bug 340277.  I think keeping patches that implement unrelated functionality in separate bugs is better than trying to shove them all in one bug.
(Reporter)

Comment 1

10 years ago
Created attachment 305717 [details] [diff] [review]
external_v1.patch
(Reporter)

Comment 2

10 years ago
The xpconnect REQUIRES in the Makefile comes from when I was trying to use xpconnect to wrap the IDispatch, but it never worked successfully.  (It wouldn't get/set/call properties).  Idealy xpconnect should be fixed up to do what is required, and then the local wrappers can be dropped.

Current status:
Get property: works,
Set property: not yet done,
Call method: works for methods that take no parameters.

Parking the patch here so that it doesn't get lost in my dev tree.

Comment 3

7 years ago
The ActiveX embedding API was removed in bug 662023 and friends, making this INVALID.

[Filter bugspam on activexinvalid]
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INVALID
(Assignee)

Updated

6 years ago
Component: Embedding: ActiveX Wrapper → Embedding: ActiveX Wrapper
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.