Loading large text page extremely slow

RESOLVED DUPLICATE of bug 72885

Status

()

Core
Layout: Text
RESOLVED DUPLICATE of bug 72885
10 years ago
4 years ago

People

(Reporter: Dolske, Unassigned)

Tracking

({perf})

Trunk
PowerPC
Mac OS X
Points:
---
Bug Flags:
wanted-next +
blocking1.9 -

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

10 years ago
On our old-style performance graphs, clicking the "Show the raw data for this plot" results in an extremely slowly loading page. Both (!) CPU cores get busy while loading, and scrolling around in the page is also painfully slow. [Specifically, scrolling vertically in the bottom half of the page, where the lines are long, is laggy. Horizontal scrolling is ok.]

Safari does a better job (although it sometimes seems to fail loading the page). It's not exactly snappy, but CPU usage doesn't have a huge prolonged spike and the scrolling is ok.

The URL linked here takes ~75 seconds to load in a current trunk nightly, and 25 seconds in Safari.
Flags: blocking1.9?
(Reporter)

Comment 1

10 years ago
With a debug build, it's slower still: takes ~225 seconds to load and beachballs the whole time.

After about 30 seconds, I start getting a flood of console output like:

nsLineLayout: Text(9920)@0x43fa12d4 metrics=567035,840!
nsLineLayout: Inline(a)(0)@0x44812a94 metrics=1122560,840!
nsLineLayout: Text(9920)@0x44812af4 metrics=1122560,840!
nsLineLayout: Inline(a)(0)@0x44812b38 metrics=1122560,840!
nsLineLayout: Text(9921)@0x43fa1314 metrics=879659,840!
nsLineLayout: Inline(a)(0)@0x44812bdc metrics=1122560,840!
nsLineLayout: Text(9921)@0x44812c3c metrics=1045053,840!
nsLineLayout: Inline(a)(0)@0x44812c80 metrics=1045053,840!
nsBlockReflowContext: Block(body)(1)@0x20118370 metrics=76920,28700562!
nsLineLayout: Text(9921)@0x43fa1314 metrics=879659,840!
nsLineLayout: Inline(a)(0)@0x44812bdc metrics=1122560,840!
nsLineLayout: Text(9921)@0x44812c3c metrics=1045053,840!
 

Updated

10 years ago
Flags: tracking1.9? → blocking1.9?
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b4pre) Gecko/2008022808 Minefield/3.0b4pre

It's a nasty hang, runs out of memory, CPU usage sometimes high and sometimes low. I waited for 5 minutes, then I had to end the process.
Does the page have unclosed tags or something like that?
(Reporter)

Comment 4

10 years ago
No, the tags appear to be closed.

  <HTML>
  <title>rawdata for bl-bldlnx03_fx-linux-tbox-head pageload</title><br>
  <body>
  <h3>Data for bl-bldlnx03_fx-linux-tbox-head pageload</h3>
  <li><a href="#plot">plot points</a></li>
  <li><a href="#raw">raw points</a></li>
  <br>
  ...

Although those two <li> entries are not in a <ul>/<ol>, which is slightly odd?

The rest of the page is mostly just 2 giant <pre>...</pre> chunks. [45MB worth, to put the "large" in the bug summary more precisely.]
Flags: wanted-next+
Flags: blocking1.9?
Flags: blocking1.9-

Comment 5

9 years ago
The problem also exists with smaller files, like this 500 KB file:
http://w-o-p-r.dk/wopr.tools/monitor/wopru.test.self.txt

It is only a problem in Firefox 3, Firefox 2 does not hang but show the files "instantly".

Comment 6

9 years ago
dupe of bug 72885?

Comment 7

8 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.4) Gecko/20100503 Firefox/3.6.4

I tried with Firefox 3.6.4 on Windows XP. It took about 5 minutes to load the given URL. Firefox hung only a bit and scrolling was quite fast, except at the bottom of the page, where it got a bit slower. CPU wasn't so bad. It rose a few times up to 95%, but it generally remained at 48-52% and lower for the most part.

Comment 8

4 years ago
none of the testcases exist, but bug 72885 is a possibility
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 72885
You need to log in before you can comment on or make changes to this bug.