CSS font-weight:bolder support

RESOLVED WONTFIX

Status

()

Core
Graphics
RESOLVED WONTFIX
10 years ago
7 years ago

People

(Reporter: karlt, Assigned: karlt)

Tracking

Trunk
x86
Linux
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Assignee)

Description

10 years ago
Currently ThebesStyleToPangoWeight maps font-weight bolder to an absolute weight, but the absolute weight should depend on the actual weights supported by the font.

One issue with this is that currently two of the steps in the 5-entry absolute weight table (649 and 749) correspond to semibold and bold weights but I haven't found a family with both of these weights.   Merging these two steps into one
would make <b>A<b>B</b></b> provide a bolder B than A for family "Arial" (if
the newer versions of Arial were available).

Attachment 300711 [details] [diff] has much of what is required to select the weight based on the first existing family in the group.
(Assignee)

Updated

10 years ago
Blocks: 419963

Comment 1

10 years ago
Don't know much about the Pango code but both Windows and Mac use similar logic to handle this.  The weights on the style come in as "relative" ones like 698 (i.e. two faces lighter than bold):

http://mxr.mozilla.org/mozilla/source/gfx/thebes/src/gfxQuartzFontCache.mm#507

See bug 411891 for testcase, the second testcase uses js to autogenerate test samples so it would be fairly easy to set it up for fonts on your Linux system.

I'm assuming you're also checking lighter with this work?
(Assignee)

Updated

9 years ago
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 93725
(Assignee)

Comment 3

9 years ago
I'm reopening this as this as the bug for Linux-specific implementation of face selection using relative steps of available weights, leaving bug 93725 for XP discussion on whether a sequence or count of relative steps is appropriate
(http://lists.w3.org/Archives/Public/www-style/2008Jun/0151.html).
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
(Assignee)

Updated

9 years ago
Assignee: nobody → mozbugz
Status: REOPENED → NEW
(Assignee)

Updated

9 years ago
Depends on: 449356

Comment 4

8 years ago
Another testcase using downloadable fonts:

http://people.mozilla.org/~jdaggett/font-face/synthetic-variations.html

Expected result: normal column text is always rendered with the regular face, italic with regular italic, etc.
Spec changes (currently in the W3C-confidential editor's draft of CSS 2.1) make this bug obsolete.
The new approach (with patch in bug 93725) make this unnecessary.
Status: NEW → RESOLVED
Last Resolved: 9 years ago7 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.