Focus: page up/down keys don't work after using right-click menu back/forward

VERIFIED WORKSFORME

Status

()

Core
Keyboard: Navigation
P3
normal
VERIFIED WORKSFORME
18 years ago
17 years ago

People

(Reporter: Jeremy Weatherford, Assigned: saari (gone))

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.2.13-4mdk i686; en-US; m15)
BuildID:    2000041811

Using the right-click menu to select 'back' means that the pageup, pagedown, and
spacebar keys do not work to scroll on the new page.  Same for 'forward'.

Reproducible: Always
Steps to Reproduce:
Steps:
1)Start Mozilla
2)Load one page
3)Load another page
4)Right-click and select 'Back' from the menu
5)Attempt to use pageup or pagedown or spacebar to scroll the page (they don't work)

Actual Results:  Nothing.  :)

Expected Results:  Supposed to scroll the page.

Comment 1

18 years ago
I see this on 60908, but I think it's just another consequence of the problem 
that you have to click within the content area for keybindings to work (once 
you use the context menu, the content area 'loses focus' and keybindings won't 
work until you click within it again).  I'll try to find the bug # for that.  
sairuh, what do you think? (->keyboard navigation)
Assignee: joki → don
Component: Event Handling → Keyboard Navigation
QA Contact: janc → szhu

Comment 2

18 years ago
oops, I forgot that sairuh's not the qa contact for keyboard nav (who is going 
to be it in the meantime, now that szhu is gone?)  well anyways, sairuh what do 
you think?

Comment 3

18 years ago
Confirmed on 060908.  Looks like Ross is right: if you click on the content
with the mouse, pageup/pagedown/etc start working again.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 4

18 years ago
Matthew, as I said, though, the fact that you have to click within the viewport 
before navigational keybindings work is a known issue and has been reported 
previously.   I just can't find it at the moment.

Comment 5

18 years ago
*spam* changing all open or resolved bugs that szhu@netscape.com was the QA 
contact for to sairuh@netscape.com.  szhu is no longer with netscape, and these 
bugs could lie dormant otherwise.  sorry for spam.
QA Contact: szhu → sairuh

Comment 6

18 years ago
mcafee, m19
Assignee: don → mcafee
Target Milestone: --- → M19

Comment 7

18 years ago
Blake: The bug you're thinking about is bug 9701 "nsWebShell Key events not
working until focus set in window."
Was marked fixed sometime february but dups have been tagged up till May this
year.

Comment 8

18 years ago
bug still here on linux, giving to saari for a look.
Assignee: mcafee → saari
Summary: page up/down keys don't work after using right-click menu back/forward → Focus: page up/down keys don't work after using right-click menu back/forward
(Assignee)

Comment 9

18 years ago
Seems to have gotten fixed... works on my current linux build.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME
mass verification of WorksForMe bugs: to find all bugspam pertaining to this,
set your search string to "IfItWorksForSlappyTheSquirrelThenItWFM".

if you think this particular bug is *still* an open issue, please make sure of
the following before reopening:

a. that it's still a problem with ***recent trunk builds*** on the all
appropriate platform[s]

b. provide clear steps to reproduce (unless a good test case is already in the
bug report), making sure it pertains to the original problem (avoid morphing as
much as possible :)
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.