Cycle collection related crashes after out of memory error?

RESOLVED WORKSFORME

Status

()

P2
critical
RESOLVED WORKSFORME
11 years ago
8 years ago

People

(Reporter: martijn.martijn, Unassigned)

Tracking

({crash, stackwanted, testcase})

Trunk
x86
Windows Vista
crash, stackwanted, testcase
Points:
---
Bug Flags:
wanted-next +
blocking1.9.1 -
wanted1.9.0.x +

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

11 years ago
See testcase, which comes from bug 347750, it needs enhanced privileges, so you need to download it to your computer.
It gives an out of memory exception, and after that open and close a bunch of tabs. I usually crash quite quickly after that.
Breakpad doesn't give any crash reports, but I attached a stack of a debug build in bug 347750:
https://bugzilla.mozilla.org/attachment.cgi?id=306330

See also comment from Ben Turner in bug 347750, comment 7:
(In reply to comment #6)
> (In reply to comment #4)
> > I'll attach the stack, it seems to crash in the cycle collector.
> 
> Looks like an out of memory exception.
> 

I see a bunch more out of memory exceptions coming from the graph builder in
just the last week, see
http://crash-stats.mozilla.com/report/list?range_unit=weeks&query_search=stack&query_type=contains&platform=windows&signature=RaiseException&query=NodePool&range_value=1

I think that needs a new bug, maybe blocking...
Flags: blocking1.9?
Version: unspecified → Trunk
Flags: blocking1.9? → wanted-next+
Priority: -- → P2
Flags: wanted1.9.1?
Flags: wanted1.9.0.x?
(Reporter)

Updated

10 years ago
Flags: blocking1.9.1?
This should get looked at in 1.9.1 at the very least...
Flags: wanted1.9.0.x? → wanted1.9.0.x+

Comment 3

10 years ago
I don't see us blocking on this unless it shows up in topcrash reports, or we can come up with a reliable diagnosis.
Flags: wanted1.9.1?
Flags: blocking1.9.1?
Flags: blocking1.9.1-
(Reporter)

Comment 4

10 years ago
In current trunk build I get a hang instead of a crash, it seems.
Flags: wanted1.9.2?
Where is it hanging?
Flags: wanted1.9.2?

Comment 6

8 years ago
I can't reproduce this on win7 with current nightly build and attachment 232545 [details].
Is a particular build needed to reproduce?
Keywords: stackwanted
(Reporter)

Updated

8 years ago
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.