Closed Bug 420157 Opened 12 years ago Closed 12 years ago

Dropdown menus hidden behind flash animation

Categories

(Firefox :: General, defect, major)

x86
Linux
defect
Not set
major

Tracking

()

VERIFIED DUPLICATE of bug 137189

People

(Reporter: david.hingos, Unassigned)

References

()

Details

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.12) Gecko/20080129 Iceweasel/2.0.0.12 (Debian-2.0.0.12-0etch1)
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.12) Gecko/20080129

On just about every site I visit that uses menus that are placed right above a large flash animation (see bestbuy.com, adobe.com, circuitcity.com - I believe these use JavaScript submenus, not sure???) I experience this issue under both firefox and iceweasel (since they do use the same code base). What happens is when the mouse pointer hovers over a menu item, the resulting submenu that drops down is rendered underneath the flash animation, so the menu itself can not be seen or used. I am using the most recent version of the flash/shockwave players for Linux. as reported by about:plugins - Shockwave Flash 9.0 r115.

Reproducible: Always

Steps to Reproduce:
1. Navigate to example site (i.e. www.bestbuy.com).
2. When page is fully displayed, mouse over the main menu (i.e.Audio, Car, etc).
3. Observe that a submenu appears under the selected option. Notice the menu appears cut off or is not visible at all, depending on your monitor resolution. Mine is set at 1680x1050.
Actual Results:  
Results are as stated above - menu is partially or fully obscured by the flash object underneath the menu.

Expected Results:  
The submenu is expected to appear over the flash object.

Note that this does not happen in Internet Explorer. I have not tested in Firefox for Windows. I have had co-workers recreate this issue on their systems as well. I am running Debian Etch, but this has been reproduced on Gentoo and Red Hat Fedora as well.

I did plenty of research prior to filing this bug report, and several message boards have posts by Linux newbies that describe this problem as well. Responses to their posts by other users include "It's the web designer's fault for writing bad code", or "Use Ad Blocker", or "Flash sucks anyway, don't use it."

These are not relevant or acceptable answers. Firefox should be capable of rendering the page as necessary for these types of sites to function as intended. I consider this a major bug as it severely cripples the use of many web sites.
This is only a issue on linux and it must be fixed in the flash plugin itself
Status: UNCONFIRMED → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 137189
v.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.