Drawing problem with Iframe when zoomed

RESOLVED DUPLICATE of bug 408913

Status

RESOLVED DUPLICATE of bug 408913
11 years ago
10 years ago

People

(Reporter: polidobj, Unassigned)

Tracking

({testcase})

Trunk
x86
Windows XP
testcase

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(4 attachments, 1 obsolete attachment)

(Reporter)

Description

11 years ago
I have a testcase which shows a drawing problem since page zoom was enabled.  Lines are drawn across the iframe when the parent page is scrolled so that the iframe is scrolled into view. Sometimes though the line are only seen drawn across the vertical scrollbar.  This predates PGO so it's not related.  

STR
1.  Zoom in on the testcase.  In recent builds you can tell when the problem will occur because a black line is visible across the bottom of the iframe, just above the bottom border.  
2. Scroll the parent window so the iframe goes out of view then scroll it back into view.  

It is expected that no lines show up.  

Attachments to follow.
Flags: blocking1.9?
(Reporter)

Comment 1

11 years ago
Created attachment 306369 [details]
testcase - child frame page
(Reporter)

Comment 2

11 years ago
Comment on attachment 306369 [details]
testcase - child frame page

Grr Wrong one
Attachment #306369 - Attachment is obsolete: true
(Reporter)

Comment 3

11 years ago
Created attachment 306370 [details]
testcase - child frame page
(Reporter)

Comment 4

11 years ago
Created attachment 306371 [details]
testcase
(Reporter)

Comment 5

11 years ago
Created attachment 306372 [details]
obilgatory screenshot 2008022806 build
(Reporter)

Comment 6

11 years ago
Created attachment 306378 [details]
Screenshot 20071221 build

At some point in the past the bug changes so instead of black lines there are lines the color of the background in the frame.  I've narrowed it down to 

20080113 black
20071221 background color

But I'm out of time for now if someone else wants to narrow it down to a day.
This is probably related to bug 376124.  Clearing the nom, we should re-evaluate this if a fix for 376124 doesn't resolve it.
Depends on: 376124
Flags: blocking1.9?
See also bug 420413, which is a regression from bug 417967.

Comment 9

11 years ago
seems to be fixed on/with
20080304_0106_firefox-3.0b5pre.en-US.win32.zip

bonsai :
http://bonsai.mozilla.org/cvsquery.cgi?module=PhoenixTinderbox&date=explicit&mindate=1204615920&maxdate=1204621559

Bug 408913 ?
(Reporter)

Comment 10

11 years ago
I'm not sure why I didn't find that bug.  Line, zoom and scroll were three keywords I searched for.  Perhaps I always had another word in my search which resulted in finding nothing.  

WFM 
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b5pre) Gecko/2008030405 Minefield/3.0b5pre ID:2008030405
so 
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 408913
(Assignee)

Updated

10 years ago
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.