Closed Bug 420401 Opened 12 years ago Closed 11 years ago

need unit tests for "Save Link As..."

Categories

(Firefox :: File Handling, defect, P2)

defect

Tracking

()

RESOLVED DUPLICATE of bug 486342

People

(Reporter: dmose, Unassigned)

References

Details

(Whiteboard: [needs patch][swag 8hr])

From bug 299372 comment 5:

For what it's worth, I think that in an ideal world, the
following things about save-link-as would get tested:

* traversing a link to an as-yet-authenticated server that requires auth
* traversing a link that's busted provides error notification
* traversing a link that doesn't return info quickly falls-back to the old
behavior
* traversing a link that does return it quickly uses it
Flags: blocking-firefox3?
Blocks: 299372
Flags: blocking-firefox3? → blocking-firefox3+
Priority: -- → P2
Shawn, I know you have a lot on your plate, but I bet you at least have ideas on how to test this stuff...
Assignee: nobody → sdwilsh
They probably aren't going to be terrible, but will probably take several hours to work out.

The hardest one will probably be the "doesn't return quickly" case.  I'm not really sure how to automate that test...
Whiteboard: [needs patch][swag 8hr]
fyi, I probably won't have cycles for this for about a month.
might dolske have cycles for this?  I probably won't be able to start on this until after April 15 at the earliest (possibly not until after April 24).
We want more testing coverage, but we have litmus tests to bridge the gap for release.
Flags: wanted1.9.0.x+
Flags: wanted-firefox3+
Flags: blocking-firefox3-
Flags: blocking-firefox3+
Assignee: sdwilsh → nobody
Forward duping to bug 486342 since work is being done there.
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 486342
You need to log in before you can comment on or make changes to this bug.