Frequent crashes when using keyboard shortcuts (EXC_BAD_ACCESS)

VERIFIED DUPLICATE of bug 420403

Status

()

Core
Widget: Cocoa
--
critical
VERIFIED DUPLICATE of bug 420403
10 years ago
10 years ago

People

(Reporter: Leander Koornneef, Assigned: Josh Aas)

Tracking

Trunk
All
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

33.28 KB, application/octet-stream
Details
(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en; rv:1.9b4pre) Gecko/2008030100 Camino/2.0a1pre (like Firefox/3.0b4pre)
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en; rv:1.9b4pre) Gecko/2008030100 Camino/2.0a1pre (like Firefox/3.0b4pre)

Since a day or two, I've had Camino (trunk) crash very frequently. 
It appears to happen when using keyboard shortcuts (Cmd-opt-arrow, 
Cmd-W, etc.). It does not happen every time, but I have not been able 
to correlate it to a specific situation or event. However, the cause
of the crash seems to be consistent:

Thread 0 Crashed:
0   libobjc.A.dylib               	0x94cce6e4 objc_msgSend + 20
1   org.mozilla.camino            	0x006a5735 -[ChildView performKeyEquivalent:] + 249
2   com.apple.AppKit              	0x944a9e44 -[NSView performKeyEquivalent:] + 367
3   com.apple.AppKit              	0x944a9e44 -[NSView performKeyEquivalent:] + 367
4   com.apple.AppKit              	0x944a9e44 -[NSView performKeyEquivalent:] + 367
5   com.apple.AppKit              	0x944a9e44 -[NSView performKeyEquivalent:] + 367
6   com.apple.AppKit              	0x944a9e44 -[NSView performKeyEquivalent:] + 367
7   org.mozilla.camino            	0x0004f28c -[BrowserContentView performKeyEquivalent:] + 120
8   com.apple.AppKit              	0x944a9e44 -[NSView performKeyEquivalent:] + 367
9   com.apple.AppKit              	0x944a9e44 -[NSView performKeyEquivalent:] + 367
10  com.apple.AppKit              	0x944a9baf -[NSWindow performKeyEquivalent:] + 257
11  org.mozilla.camino            	0x000406e2 -[BrowserWindow performKeyEquivalent:] + 440
12  com.apple.AppKit              	0x944a9874 -[NSApplication _handleKeyEquivalent:] + 99
13  com.apple.AppKit              	0x943c6b36 -[NSApplication sendEvent:] + 3838
14  com.apple.AppKit              	0x943240f9 -[NSApplication run] + 847
15  com.apple.AppKit              	0x942f130a NSApplicationMain + 574
16  org.mozilla.camino            	0x0000324c main + 196
17  org.mozilla.camino            	0x00002b1e _start + 216
18  org.mozilla.camino            	0x00002a45 start + 41

I'll attach a complete copy of one of the crash logs to this post.

Reproducible: Sometimes

Steps to Reproduce:
1.
2.
3.
(Reporter)

Comment 1

10 years ago
Created attachment 306747 [details]
Camino crash log

Updated

10 years ago
Assignee: nobody → joshmoz
Component: General → Widget: Cocoa
Product: Camino → Core
QA Contact: general → cocoa
Version: unspecified → Trunk
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Hardware: Macintosh → All
Resolution: --- → DUPLICATE
Duplicate of bug: 420403

Updated

10 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.