Crashes when searching words

VERIFIED DUPLICATE of bug 322143

Status

()

Firefox
Search
--
critical
VERIFIED DUPLICATE of bug 322143
10 years ago
10 years ago

People

(Reporter: Allan Hobbs, Unassigned)

Tracking

({crash})

2.0 Branch
x86
Windows XP
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.8.1.12) Gecko/20080201 Firefox/2.0.0.12
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.8.1.12) Gecko/20080201 Firefox/2.0.0.12

If I search on words it crashes 60% of the time.
ie "super"
We have 3 PC's all running XP and all suffer the same problems.
I always send the error reports.
In this example though PC 3 didn't crash, only PC's 1 & 2.

Reproducible: Always

Steps to Reproduce:
1. type super and click search
2.
3.
Actual Results:  
Firefox has encountered a problem and needs to close.

Then,
firefox.exe Application error
The instruction at "0x642090db" referenced memory at 0x00090141". The memory  could not be "read"


Addons
Download Statusbar 0.9.6  - on all 3 PC's
Fasterfox 2.0.0  - on PC 1 & 2
Net Usage Item 1.2.177.1 - on PC 1 only
XPL LinkScanner Firefox 2.6 - on all 3 PC's
Englist (Australian) Dictionary 2.1.1 - on PC's 2 & 3

PC 1 & 3 have XP Pro and PC 2 has XP home
We need talkback IDs for your crashes
- http://kb.mozillazine.org/Talkback

Also, make sure the crash is reproducible with a new firefox profile:
- http://kb.mozillazine.org/Profile_manager
(Do not delete your existing profile)

If the crash does not happen with a new profile, then it is probably being caused by one of your extensions; in which case you should disable them one-by-one until the crash goes away, and then you have your culprit.
Keywords: crash
Version: unspecified → 2.0 Branch
(Reporter)

Comment 2

10 years ago
Talkback installed and error sent
Please run talkback.exe and report here the TalkBackID number (looks like TB3897632967J or some such)
(Reporter)

Comment 4

10 years ago
I've found the problem - or all is okay so far.
I will test for a day or so and report back.
It was XPL LinkScanner Firefox 2.6 - on all 3 PC's
I couldn't uninstall only allows "disable"

Do you still want the TalkbackID?
OK report back in a day, that'd be good. The Talkback data might still be useful, even if it's just for finding other bugs that have been filed about the same issue, but it's not absolutely required.

Comment 6

10 years ago
Incident ID: 42120212
Stack Signature	Detecting e55e4a98
Product ID	Firefox2
Build ID	2008020121
Trigger Time	2008-03-02 04:23:57.0
Platform	Win32
Operating System	Windows NT 5.1 build 2600
Module	js3250.dll + (000322f0)
URL visited	see ref below
User Comments	https://bugzilla.mozilla.org/show_bug.cgi?id=420560
Since Last Crash	97 sec
Total Uptime	97 sec
Trigger Reason	Access violation
Source File, Line No.	c:/builds/tinderbox/Fx-Mozilla1.8-Release/WINNT_5.2_Depend/mozilla/js/src/jsobj.c, line 3131
Stack Trace 	
Detecting  [mozilla/js/src/jsobj.c, line 3131]
js_LookupProperty  [mozilla/js/src/jsobj.c, line 3174]
js_GetProperty  [mozilla/js/src/jsobj.c, line 3552]
nsXPCWrappedJSClass::CallQueryInterfaceOnJSObject  [mozilla/js/src/xpconnect/src/xpcwrappedjsclass.cpp, line 243]
nsXPCWrappedJSClass::DelegatedQueryInterface  [mozilla/js/src/xpconnect/src/xpcwrappedjsclass.cpp, line 633]
nsXPCWrappedJS::QueryInterface  [mozilla/js/src/xpconnect/src/xpcwrappedjs.cpp, line 106]
nsEventListenerManager::HandleEvent  [mozilla/content/events/src/nsEventListenerManager.cpp, line 1752]
nsXULElement::HandleDOMEvent  [mozilla/content/xul/content/src/nsXULElement.cpp, line 2234]
nsXULElement::HandleDOMEvent  [mozilla/content/xul/content/src/nsXULElement.cpp, line 2257]
nsXULElement::HandleDOMEvent  [mozilla/content/xul/content/src/nsXULElement.cpp, line 2257]
nsXULElement::HandleDOMEvent  [mozilla/content/xul/content/src/nsXULElement.cpp, line 2257]
nsXULElement::HandleDOMEvent  [mozilla/content/xul/content/src/nsXULElement.cpp, line 2257]
nsXULElement::HandleChromeEvent  [mozilla/content/xul/content/src/nsXULElement.cpp, line 2899]
nsGlobalWindow::HandleDOMEvent  [mozilla/dom/src/base/nsGlobalWindow.cpp, line 1761]
nsDocument::HandleDOMEvent  [mozilla/content/base/src/nsDocument.cpp, line 4149]
nsGenericElement::HandleDOMEvent  [mozilla/content/base/src/nsGenericElement.cpp, line 2269]
nsGenericElement::HandleDOMEvent  [mozilla/content/base/src/nsGenericElement.cpp, line 2261]
nsGenericElement::HandleDOMEvent  [mozilla/content/base/src/nsGenericElement.cpp, line 2261]
nsGenericElement::HandleDOMEvent  [mozilla/content/base/src/nsGenericElement.cpp, line 2261]
nsGenericElement::HandleDOMEvent  [mozilla/content/base/src/nsGenericElement.cpp, line 2261]
nsGenericElement::HandleDOMEvent  [mozilla/content/base/src/nsGenericElement.cpp, line 2261]
nsGenericElement::HandleDOMEvent  [mozilla/content/base/src/nsGenericElement.cpp, line 2261]
nsGenericElement::HandleDOMEvent  [mozilla/content/base/src/nsGenericElement.cpp, line 2261]
nsGenericElement::HandleDOMEvent  [mozilla/content/base/src/nsGenericElement.cpp, line 2261]
nsEventStateManager::DispatchMouseEvent  [mozilla/content/events/src/nsEventStateManager.cpp, line 2797]
nsEventStateManager::NotifyMouseOver  [mozilla/content/events/src/nsEventStateManager.cpp, line 2922]
nsEventStateManager::GenerateMouseEnterExit  [mozilla/content/events/src/nsEventStateManager.cpp, line 2954]
nsEventStateManager::PreHandleEvent  [mozilla/content/events/src/nsEventStateManager.cpp, line 567]
PresShell::HandleEventInternal  [mozilla/layout/base/nsPresShell.cpp, line 6515]
PresShell::HandleEvent  [mozilla/layout/base/nsPresShell.cpp, line 6356]
nsViewManager::HandleEvent  [mozilla/view/src/nsViewManager.cpp, line 2566]
nsViewManager::DispatchEvent  [mozilla/view/src/nsViewManager.cpp, line 2253]
HandleEvent  [mozilla/view/src/nsView.cpp, line 174]
nsWindow::DispatchEvent  [mozilla/widget/src/windows/nsWindow.cpp, line 1319]
nsWindow::DispatchMouseEvent  [mozilla/widget/src/windows/nsWindow.cpp, line 6329]
ChildWindow::DispatchMouseEvent  [mozilla/widget/src/windows/nsWindow.cpp, line 6576]
nsWindow::WindowProc  [mozilla/widget/src/windows/nsWindow.cpp, line 1507]
USER32.dll + 0x8734 (0x7e418734)
USER32.dll + 0x8816 (0x7e418816)
USER32.dll + 0x89cd (0x7e4189cd)
USER32.dll + 0x8a10 (0x7e418a10)
nsAppShell::Run  [mozilla/widget/src/windows/nsAppShell.cpp, line 159]
nsAppStartup::Run  [mozilla/toolkit/components/startup/src/nsAppStartup.cpp, line 152]
main  [mozilla/browser/app/nsBrowserApp.cpp, line 61]
kernel32.dll + 0x16fd7 (0x7c816fd7)
Whiteboard: DUPEME
The stack looks a lot like bug 319533 I think.
As timeless said in bug 319533 comment 19, new bugs should be filed if this crash happens again. I think we should let handle this bug the 2.0 branch. Confirming based on the Talkback report.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Whiteboard: DUPEME
But looks like bug 322143 which is filed for 2.0 branch. Timeless what do you think?

Comment 10

10 years ago
yes
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 322143
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.