SessionStore API doesn't save desktop where window is located.

RESOLVED DUPLICATE of bug 372650

Status

()

--
enhancement
RESOLVED DUPLICATE of bug 372650
11 years ago
11 years ago

People

(Reporter: clint.bowman, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.12) Gecko/20080208 Fedora/2.0.0.12-1.fc7 Firefox/2.0.0.12
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.12) Gecko/20080208 Fedora/2.0.0.12-1.fc7 Firefox/2.0.0.12

I spread 20+ Firefox windows across a half dozen KDE desktops and if Firefox crashes I spend too much time assigning the restored configuration back to the desired desktops.  

Because KDE is able to put applications and xterms onto the correct destops and in the previous positions and with the previous sizes, I'm sure that many of the hooks must be available for incorporation into the SessionStore API.  

I don't use Gnome but suspect the problem exists there also.  Because Vista is purported to support multiple desktops, I suspect that the Windows community will soon complain (good luck on that one as I'll bet the Microsoft is using a completely different approach.)

Reproducible: Always

Steps to Reproduce:
1.In KDE, expand the number of desktops to 20
2.Open up 20 Firefox windows and put them on eight of the desktops
3.Crash Firefox.
Actual Results:  
Session Restore seems to randomly assign the Firefox windows to KDE desktops--often all of the windows are put on one desktop.

Expected Results:  
Each Firefox window should be put back on the same (KDE) desktop in the same relative location and at the same size.

Comment 1

11 years ago
i highly doubt such information is currently available to session restore.

out of curiosity, what happens if your desktop configuration changes? or is that too unlikely? (some desktop managers definitely let you add/remove desktops, and if firefox were to want to restore to desktop 9 of 8, I'd like to know what it should do).

virtual desktops existed in nt4 (they were just not very visible), sadly I can't remember the name/address of one of the tiny cool applets that let one access them.
(Reporter)

Comment 2

11 years ago
(In reply to comment #1)
> i highly doubt such information is currently available to session restore.

Interestingly enough, sometimes the windows are restored correctly--I'm wondering how that happens????  Is there an interaction between the window manager and firefox that assigns windows to desktops?

> 
> out of curiosity, what happens if your desktop configuration changes? or is
> that too unlikely? 

In my case--not likely I'm pretty fixed in my ways but others may be more dynamic.

(some desktop managers definitely let you add/remove
> desktops, and if firefox were to want to restore to desktop 9 of 8, I'd like to
> know what it should do).

If the number of desktops decreased below the highest desktop previously used to hold FF windows, pop up a message informing the user that the number of desktops had decreased and ask if they should be restored to the current desktop as separate windows or put in a single window as tabs.

> 
> virtual desktops existed in nt4 (they were just not very visible), sadly I
> can't remember the name/address of one of the tiny cool applets that let one
> access them.
> 

Updated

11 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 372650
You need to log in before you can comment on or make changes to this bug.