Last Comment Bug 420663 - [Mac]Drag and Drop of image to desktop creates icon at wrong place
: [Mac]Drag and Drop of image to desktop creates icon at wrong place
Status: VERIFIED DUPLICATE of bug 401380
:
Product: Firefox
Classification: Client Software
Component: Shell Integration (show other bugs)
: Trunk
: PowerPC Mac OS X
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
: Robert Strong [:rstrong] (use needinfo to contact me)
Mentors:
http://www.mozilla.com/en-US/firefox/...
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-02 22:22 PST by Louise
Modified: 2008-04-05 07:45 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Louise 2008-03-02 22:22:23 PST
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9b4pre) Gecko/2008030204 Minefield/3.0b4pre
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9b4pre) Gecko/2008030204 Minefield/3.0b4pre

When you drag and drop image files from web page to desktop, the icon is always created from top right corner.
The icon of the saved image should be created at the point mouse button was released, as Safari does.


Reproducible: Always

Steps to Reproduce:
1.Drag image from above URL to Desktop
2.Drop it at the point where you want the file to stay.

Actual Results:  
The icon is created on the top right (or if there are already some files, left to them) 

Expected Results:  
Icon should be created at the point you release mouse button.
Comment 1 philippe (part-time) 2008-03-03 18:08:57 PST

*** This bug has been marked as a duplicate of bug 401380 ***

Note You need to log in before you can comment on or make changes to this bug.