Crash if I click on label in node "Last Labels" of bookmarks tree

RESOLVED DUPLICATE of bug 400109

Status

()

Firefox
Bookmarks & History
RESOLVED DUPLICATE of bug 400109
10 years ago
8 years ago

People

(Reporter: Dmitry, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; ru; rv:1.9b3) Gecko/2008020514 Firefox/3.0b3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; ru; rv:1.9b3) Gecko/2008020514 Firefox/3.0b3

ASSERT: Node QI Failed
Stack Trace: 
0:QI_node([xpconnect wrapped nsINavHistoryResultNode],nsINavHistoryQueryResultNode)
1:asQuery([xpconnect wrapped nsINavHistoryResultNode])
2:PU_nodeIsReadOnly([xpconnect wrapped nsINavHistoryResultNode])
3:PC_isCommandEnabled(placesCmd_sortBy:name)
4:isCommandEnabled(placesCmd_sortBy:name)
5:updatePlacesCommand(placesCmd_sortBy:name)
6:goUpdatePlacesCommands()
7:oncommandupdate([object Event])

ASSERT: Node QI Failed
Stack Trace: 
0:QI_node([xpconnect wrapped nsINavHistoryResultNode],nsINavHistoryQueryResultNode)
1:asQuery([xpconnect wrapped nsINavHistoryResultNode])
2:PU_nodeIsReadOnly([xpconnect wrapped nsINavHistoryResultNode])
3:PC_isCommandEnabled(placesCmd_sortBy:name)
4:isCommandEnabled(placesCmd_sortBy:name)
5:updatePlacesCommand(placesCmd_sortBy:name)
6:goUpdatePlacesCommands()
7:oncommandupdate([object Event])
8:updateCommands(focus)
9:onxblfocus([object Event])

etc, I see about 10 asserts with same messages. I can send it to you if need.


Reproducible: Always

Steps to Reproduce:
1. Create any bookmark
2. Open window "Show all bookmarks" (Ctrl + Shift + B)
3. Select your bookmark and type in "Labels" field any word
4. This word will appear in "Last Labels" node.
5. Click on it.
Component: Bookmarks → Places
QA Contact: bookmarks → places

Updated

10 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 400109
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.