MoFo EULA URI redirects to MoCo EULAS for non-MoCo products

RESOLVED DUPLICATE of bug 368091

Status

RESOLVED DUPLICATE of bug 368091
11 years ago
6 years ago

People

(Reporter: stefanh, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

11 years ago
STR:

1) Launch Camino or SeaMonkey (non-MoCo products)
2) type http://www.mozilla.org/foundation/EULA/ in the address field an hit enter
3) Note that you end up at http://en.www.mozilla.com/en/legal/eula/ which only has EULAs for MoCo products.
I believe the correct URL is http://www.mozilla.org/legal/eula/

Do we link to the other one? :-/
(Reporter)

Comment 2

11 years ago
(In reply to comment #1)
> I believe the correct URL is http://www.mozilla.org/legal/eula/
> 
> Do we link to the other one? :-/
> 

Yes, in about:license. But Camino is using the xpfe version, right? SeaMonkey is using the toolkit version...
Ew, yes. Sounds like the toolkit one needs to be fixed. Alternatively, we could link to http://www.mozilla.org/foundation/licensing.html, but that's a bit more detail than most users want (not that the EULA isn't...).
(Reporter)

Comment 4

11 years ago
Yeah, the toolkit one looks wrong for seamonkey anyway since it says "Official binaries of this product released by the Mozilla Corporation  are made available under the corresponding EULA." Hmm.
(In reply to comment #4)
> Yeah, the toolkit one looks wrong for seamonkey anyway since it says "Official
> binaries of this product released by the Mozilla Corporation  are made
> available under the corresponding EULA." Hmm.

Bug 368091

We should have the Foundation EULA page redirect to http://www.mozilla.org/legal/eula/ since that page lists all the Foundation EULAs and provides prominent links to Corp EULAs.
OS: Mac OS X → All
Hardware: PC → All
(Reporter)

Comment 6

11 years ago
(In reply to comment #5)
> (In reply to comment #4)
> > Yeah, the toolkit one looks wrong for seamonkey anyway since it says "Official
> > binaries of this product released by the Mozilla Corporation  are made
> > available under the corresponding EULA." Hmm.
> 
> Bug 368091
> 
> We should have the Foundation EULA page redirect to
> http://www.mozilla.org/legal/eula/ since that page lists all the Foundation
> EULAs and provides prominent links to Corp EULAs.

Yeah, or possibly just redirect SeaMonkey/Camino (you'll use the toolkit one sooner or later) and at the same time tweak the wording in toolkit's license.html to say something like: "Official binaries of this product released by Mozilla Corporation or Mozilla Foundation are made available under the corresponding EULA.".

(Reporter)

Comment 7

11 years ago
fwiw, re bug 368091: whatever happens with the redirect I think we need a temporary fix for the toolkit license.html since seamonkey already includes it...
(In reply to comment #6)
> Yeah, or possibly just redirect SeaMonkey/Camino (you'll use the toolkit one

Redirecting based on app will work fine for browser-apps, but if you open this file in Tb or Sb (assuming it opens in a chrome window instead of just your default browser to begin with), clicking that link should open it your default browser, which may not be an app that will get you redirected to to right page for your non-browser-app's EULA. :-(
OS: All → Mac OS X
Hardware: All → PC
So, if it's a problem with the app content itself, is there anything for me to do on www.mozilla.org?
OS: Mac OS X → All
Hardware: PC → All
Depending on the ability to get a short-term fix of bug 368091, we may still end up needing to globally redirect http://www.mozilla.org/foundation/EULA/ to some place not MoCo-specific.  

(Just *reading* the URL itself screams we should redirect it to another relevant /foundation/ page ;) but AFAIK the only place that URL is mentioned/used/linked is in the client apps, so if the client apps are fixed, it's not pressing....)
OS: All → Mac OS X
Hardware: All → PC
(Reporter)

Comment 11

11 years ago
I think I'll dupe this one. Whatever we have to do on m.o, we still need to tweak toolkit's license.html because we need to change the wording. And if we change the wording, we could change the URL at the same time. If nothing have happened with bug 368091 when it's release-time, a new bug for a m.o hack should probably be filed...
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 368091
(Assignee)

Updated

11 years ago
Product: mozilla.org → Websites
Component: www.mozilla.org → General
Product: Websites → www.mozilla.org
You need to log in before you can comment on or make changes to this bug.