Crash on exit while caldav-Calendars are being reloaded [@ OperationStreamListener::OnStopRequest]

RESOLVED FIXED in 0.8

Status

Calendar
General
--
critical
RESOLVED FIXED
10 years ago
7 years ago

People

(Reporter: Armin Fuerst, Unassigned)

Tracking

({crash})

unspecified
x86
Windows XP
crash

Details

(crash signature)

Attachments

(1 obsolete attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.12) Gecko/20080201 Firefox/2.0.0.12
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.8pre) Gecko/20071023 Sunbird/0.7

If Sunbird is exited while Sunbird reloads remote calendars (caldav), it crashes. This might be a duplicate of Bug 416239.

Reproducible: Always

Steps to Reproduce:
1. Wait until Sunbird reloades remote calendars
2. Close the program while Sunbird reloades remote calendars

Actual Results:  
Sunbird crashes, Netscape quality feedback agent starts.

Expected Results:  
Sunbird should close silently
Yes, probably a duplicate of Bug 416239. Does the issue still exists using a recent Sunbird 0.8pre nightly build with the fix from Bug 416239?

Do you have a Talkback Crash Report ID?
(Reporter)

Comment 2

10 years ago
(In reply to comment #1)
> Yes, probably a duplicate of Bug 416239. Does the issue still exists using a
> recent Sunbird 0.8pre nightly build with the fix from Bug 416239?

I'm using Sunbird in my production environment that's why I usually don't
use nightly builds. Is the Sunbird 0.8pre at least as stable as the
0.7 version so I can risk the upgrade?

> Do you have a Talkback Crash Report ID?

It happend several times the last days, but I couldn't reproduce it yet.
As soon as it happens again, I'll try to create the report.
(Reporter)

Comment 3

10 years ago
Created attachment 307400 [details]
Talkback Details

When the error occurred the last time, I saved the details of the Talkback Agent.

Comment 4

10 years ago
Comment on attachment 307400 [details]
Talkback Details

we need the incident id, not the raw data, which is only shown to you so that you can see what you're sending to us. it isn't meaningful in this form.
Attachment #307400 - Attachment is obsolete: true
(Reporter)

Comment 5

10 years ago
(In reply to comment #4)
> (From update of attachment 307400 [details])
> we need the incident id, not the raw data, which is only shown to you so that
> you can see what you're sending to us. it isn't meaningful in this form.

I also sent the report, but I didn't get any info of how
I can access or reference to the report. Can you assist
me with this?
(Reporter)

Comment 6

10 years ago
> Do you have a Talkback Crash Report ID?

I think I found the 2 IDs: 42209484 and 42254513

(Reporter)

Comment 7

10 years ago
The problem did not occur since my upgrade to following nightly build:

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.13pre) Gecko/20080306 Sunbird/0.8

I'm not sure whether it is really solved or just accidentally working, so I leave the but as UNCONFIRMED.

Comment 8

10 years ago
Incident ID: 42254513
Stack Signature	OperationStreamListener::OnStopRequest dd9761a9
Product ID	Sunbird05
Build ID	2007102306
Trigger Time	2008-03-05 07:40:41.0
Platform	Win32
Operating System	Windows NT 5.1 build 2600
Module	sunbird.exe + (003ea123)
URL visited	
User Comments	Close Sunbird
Since Last Crash	
Total Uptime	
Trigger Reason	Access violation
Source File, Line No.	c:/builds/tinderbox/Sb-Mozilla1.8/WINNT_5.2_Depend/mozilla/extensions/webdav/src/nsOperationStreamListeners.cpp
Stack Trace 	
OperationStreamListener::OnStopRequest  [mozilla/extensions/webdav/src/nsOperationStreamListeners.cpp, line 162]
nsHttpChannel::OnStopRequest  [mozilla/netwerk/protocol/http/src/nsHttpChannel.cpp, line 4121]
Severity: normal → critical
Keywords: crash
Summary: Crash on exit while caldav-Calendars are being reloaded → Crash on exit while caldav-Calendars are being reloaded [@ OperationStreamListener::OnStopRequest]
Resolving as FIXED per Comment #7 by the checkin of attachment 302880 [details] [diff] [review] in Bug 416239. In addition Talkback report page doesn't list this crash within the top crashers anymore (compared to Bug 416239 Comment #4).
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Depends on: 416239
Resolution: --- → FIXED
Target Milestone: --- → 0.8
(Assignee)

Updated

7 years ago
Crash Signature: [@ OperationStreamListener::OnStopRequest]
You need to log in before you can comment on or make changes to this bug.