Closed Bug 420854 Opened 12 years ago Closed 12 years ago

Cannot modify events on CalDAV calendar

Categories

(Calendar :: Provider: CalDAV, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: browning, Assigned: browning)

Details

(Keywords: regression)

Attachments

(1 file)

When trying to modify an event on a CalDAV server I get:

Error: [Exception... "'Can not modify immutable data container' when calling method: [calIItemBase::generation]"  nsresult: "0x80460002 (NS_ERROR_OBJECT_IS_IMMUTABLE)"  location: "JS frame :: file:///home/bruno/dloads/sunbird/js/calDavCalendar.js :: caldavMI :: line 504"  data: no]
Source File: file:///home/bruno/dloads/sunbird/js/calDavCalendar.js
Line: 504

Regression window: the 2008-03-02-19 nightly works, the 2008-03-03-19 nightly does not.
Flags: blocking-calendar0.8?
Keywords: regression
This lets us modify items on CalDAV again. Makes me wonder, though, what other code we might have that relies on the idl's promise that modifyItem() will be called with a mutable aNewItem.
Assignee: nobody → browning
Status: NEW → ASSIGNED
Attachment #307363 - Flags: review?(philipp)
This blocks. We need to checkin the CalDAV patch ASAP, but we will try to fix the WCAP side after the RC1.
Flags: blocking-calendar0.8? → blocking-calendar0.8+
Oops, wrong bug.
Comment on attachment 307363 [details] [diff] [review]
don't set generation in modifyItem

r=ctalbert, this looks good and I can vet that it works.  Went ahead and checked it in too so it can get into the RC.  

We do need to get some XPCShell tests for this mutable/non-mutable modify items stuff.  I wonder how much of this is due to the generation woes that all started with the "Undo bug".
Attachment #307363 - Flags: review?(philipp) → review+
As I said, I reviewed and checked in on branch and trunk.

--> Fixed

Setting QAWanted and InTestsuite flags so that the QA folks (i.e. me, Sebo or mschroeder, or <insert your name here>) can write some XPCShell tests for it.
Status: ASSIGNED → RESOLVED
Closed: 12 years ago
Flags: in-testsuite?
Keywords: qawanted
Resolution: --- → FIXED
Also checked in on SUNBIRD_0_8_BRANCH sorry for the spam
OS: Linux → All
Hardware: PC → All
Target Milestone: --- → 0.8
You need to log in before you can comment on or make changes to this bug.