Last Comment Bug 420874 - "script stack space quota is exhausted" error
: "script stack space quota is exhausted" error
Status: VERIFIED DUPLICATE of bug 420869
: testcase
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: Trunk
: x86 Windows XP
: -- normal (vote)
: ---
Assigned To: general
:
: Jason Orendorff [:jorendorff]
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-04 08:05 PST by Steve England [:stevee]
Modified: 2008-03-18 02:13 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
testcase to show "script stack space quota is exhausted" error (1.09 KB, text/html)
2008-03-04 08:05 PST, Steve England [:stevee]
no flags Details

Description Steve England [:stevee] 2008-03-04 08:05:06 PST
Created attachment 307238 [details]
testcase to show "script stack space quota is exhausted" error

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b5pre) Gecko/2008030405 Minefield/3.0b5pre ID:2008030405

I'm filing this on behalf of Morac from the mz forums. ( http://forums.mozillazine.org/viewtopic.php?t=633782 ) I won't pretend to understand the code, or know if this expected behaviour or not, but it's a change when compared to Firefox 2 so I'm filing it.

1. New profile, start firefox
2. Load testcase.
3. A dialog appears with the number '1' in it. Click OK.

Firefox 2 gives: "stack space reached 3276800 bytes without throwing an exception."

Firefox 3 gives:  InternalError : script stack space quota is exhauested. stack space quota is somewhere between: 409600 and 819200
Comment 1 Michael Kraft [:morac] 2008-03-04 08:40:53 PST
I already filed this under bug 420869, but that is still listed as UNCONFIRMED, while this is NEW.  One should be duped to the other.
Comment 2 Steve England [:stevee] 2008-03-04 08:43:35 PST
Sorry Michael!

*** This bug has been marked as a duplicate of bug 420869 ***

Note You need to log in before you can comment on or make changes to this bug.