Multiple Assertion Failed alerts on clicking items in History sidebar

VERIFIED FIXED in Firefox 3 beta5

Status

()

Firefox
Bookmarks & History
P2
major
VERIFIED FIXED
10 years ago
8 years ago

People

(Reporter: IU, Assigned: Ondrej Brablc)

Tracking

(Blocks: 1 bug, {regression})

Trunk
Firefox 3 beta5
regression
Points:
---
Dependency tree / graph
Bug Flags:
blocking-firefox3 +

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b5pre) Gecko/2008030405 Minefield/3.0b5pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b5pre) Gecko/2008030405 Minefield/3.0b5pre

If you click an item in the History sidebar while the view setting is "By Last Visited", you get multiple successive "Assertion Failed" messages.  When this happens, the item at the top of the list (i.e. the most recent history entry) also goes blank.

Reproducible: Always

Steps to Reproduce:
Note: You may also need a wheel mouse to reproduce this.

1. Create a new profile
2. Start Fx with the new profile
3. Open the history sidebar: View --> Sidebar --> History
4. Change the History sidebar view to "By Last Visited"
5. Click one of the history items in the sidebar
6. Wait a few seconds and you should see some "Assertion Failed" messages
7. If no "Assertion Failed" messages have yet appeared, with the mouse pointer over the history item you clicked, toggle your scroll wheel up and down several times.
(Reporter)

Comment 1

10 years ago
By the way, this might be a duplicate of Bug 380387
Version: unspecified → Trunk
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b5pre) Gecko/2008030405 Minefield/3.0b5pre ID:2008030405

I see this too.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Same on Vista HP.  If you try and click the 'View' button to change back to 'By Date' more asserts pour out, and its impossible to change without crashing the browser. 

Also while trying to add this, the t-box decided to 'refresh' and then I started getting 'mouse event' asserts everytime I tried to move the mouse.  

Ended up killing browser with Task Manager.

Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9b5pre) Gecko/2008030405 Minefield/3.0b5pre Firefox/3.0 ID:2008030405

Updated

10 years ago
Component: History → Places
Flags: blocking-firefox3?
QA Contact: history → places
Component: Places → History
Component: History → Places
Works: 20080304_0245_firefox-3.0b5pre.en-US.win32
Broken: 20080304_0427_N_firefox-3.0b5pre.en-US.win32

Checkins to module PhoenixTinderbox between 2008-03-04 02:45 and 2008-03-04 04:26 : 
http://bonsai.mozilla.org/cvsquery.cgi?module=PhoenixTinderbox&date=explicit&mindate=1204627500&maxdate=1204633619

Due to bug 417042?
Keywords: regression
Errors looks like:

ASSERT: null node
Stack Trace:
  0:PU_nodeIsContainer(undefined)
  1:PTV_isContainer(0)

ASSERT: null node
Stack Trace:
  0:PU_nodeIsContainer(undefined)
  1:PTV_isSeparator(0)

ASSERT: null node
Stack Trace:
  0:PU_nodeIsContainer(undefined)
  1:PTV_isContainer(0)

ASSERT: null node
Stack Trace:
  0:PU_nodeIsSeparator(undefined)
  1:PVT_getImageSrn(0,[object TreeColumn])

ASSERT: null node
Stack Trace:
  0:PU_nodeIsContainer(undefined)
  1:PTV_isContainer(0)

ASSERT: null node
Stack Trace:
  0:PU_nodeIsSeparator(undefined)
  1:PVT_getImageSrn(0,[object TreeColumn])

and seem to be never-ending
The Error Console reports following:

Error: aNode is undefined
Source File: chrome://browser/content/places/utils.js
Line: 280

>     return (aNode.type == Ci.nsINavHistoryResultNode.RESULT_TYPE_SEPARATOR);


Error: aNode is undefined
Source File: chrome://browser/content/places/utils.js
Line: 382

>     return this.containerTypes.indexOf(aNode.type) != -1;


Error: aNode is undefined
Source File: chrome://browser/content/places/utils.js
Line: 382

>     var nodeType = node.type;


Error: this._visibleElements[aRow].node is undefined
Source File: chrome://browser/content/places/treeView.js
Line: 1091

>    return this._visibleElements[aRow].node.indentLevel;
Blocks: 420915
Same with Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9b5pre) Gecko/2008030404 Minefield/3.0b5pre
OS: Windows XP → All
Hardware: PC → All
(Assignee)

Comment 8

10 years ago
This was a bad patch in bug 417042. I have reopened the bug and posted a fixing patch there already.
Assignee: nobody → ondrej
(In reply to comment #8)
> This was a bad patch in bug 417042. I have reopened the bug and posted a fixing
> patch there already.

As I see this wasn't going into b4, correct? 

I see this also if I want to create a new folder in the Library.
The folder is created successfully, however.
Blocks: 417042
(In reply to comment #8)
> This was a bad patch in bug 417042. I have reopened the bug and posted a fixing
> patch there already.

So is this fixed now that bug 417042 is fixed? If so, please resolve this bug, too.
Flags: blocking-firefox3? → blocking-firefox3+
Priority: -- → P2
Duplicate of this bug: 420984
This seems to have been corrected with the update to the patch in Comment #9 
Using today's build:

Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9b5pre) Gecko/2008030506 Minefield/3.0b5pre Firefox/3.0 ID:2008030506
Flags: blocking-firefox3+ → blocking-firefox3?
Flags: blocking-firefox3? → blocking-firefox3+
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b5pre) Gecko/2008030504 Minefield/3.0b5pre ID:2008030504

This problem is now fixed for me too, but I will let the reporter mark it RESOLVED FIXED.
(Reporter)

Comment 15

10 years ago
Fix confirmed.  As requested, marking this as RESOLVED FIXED.  Thank you Steve for identifying the cause and Ondrej for the patch.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
Verified with Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9b5pre) Gecko/2008030504 Minefield/3.0b5pre
Status: RESOLVED → VERIFIED
Target Milestone: --- → Firefox 3 beta5
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.