Closed Bug 421031 Opened 13 years ago Closed 13 years ago

100% Ts regression on cb-xserve01 across the board ca. 20:00 on 3 March

Categories

(Camino Graveyard :: General, defect)

PowerPC
macOS
defect
Not set
major

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: alqahira, Unassigned)

Details

All three branches, right about that time.  No cross-branch checkins (in fact, the only checkin at all across the entire repo (at least according to bonsai) was a jst trunk checkin), and boxset experienced no noticeable change.

This seems to imply some sort of issue with the box itself; I don't know if we can tell anything ourselves, or if we need to call IT.

CmTrunk:    437ms -> 939ms (115%) !!! 
Cm1.6-M1.8: 379ms -> 938ms (96%) !!! 
Cm1.5-M1.8: 385ms -> 461ms (20%)
I logged in via VNC and didn't see anything unusual (no windows open or anything).
Hm, so I kind of lied. There was a Camino window open. I assumed it was running tests, but turns out it was an extra window. I've closed it and Ts numbers have gone down some, but not back to where they were. (And Cm1.5-M1.8 has gone up!)

CmTrunk:    939ms -> 684ms
Cm1.6-M1.8: 937ms -> 560ms
Cm1.5-M1.8: 461ms -> 563ms
I restarted cb-xserve01. However, I restarted it just after midnight and I don't feel like waiting up until all the builds are done. The only result so far is from Cm1.5-M1.8 which reports 529ms. Not low enough yet... :-/
The two branches had single-cycle dips, while the trunk just kept on trucking :(

CmTrunk:    809ms -> 807ms -> 808ms 
Cm1.6-M1.8: 560ms -> 547ms -> 558ms 
Cm1.5-M1.8: 563ms -> 529ms -> 561ms 
This just happened again...mento noticed a very high Ts on 1.6rc1, so he restarted (but not before the 1_5 branch reported in with 563ms -> 919ms, on no checkins).  He then hid the Terminal window (instead of minimized it) and killed a hung VNC

CmTrunk:    812ms -> 1048ms -> 803ms
Cm1.6-M1.8: 560ms ->  921ms -> 550ms
Cm1.5-M1.8: 563ms ->  919ms -> 554ms

So while we've fixed today's hit, there's something still not right :(
I didn't kill a hung VNC, I speculated that either my terminal action dropped Ts back to normal, OR that logging in via VNC killed a previously-hung session.
Post-resurrection, cb-x1 (now cb-x1.local) is showing numbers

CmTrunk:    ~460ms
Cm1.6-M1.8: ~390ms

Those are still higher than 437ms and 379ms by 10-20ms, but it's close enough that I think we can reasonably blame the high numbers on cb-x1 starting to get sick and close this now that it's been to the doctor.
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.