Firefox won't prompt to change stored passwords

RESOLVED FIXED in mozilla1.9beta5

Status

()

Toolkit
Password Manager
P2
normal
RESOLVED FIXED
9 years ago
9 years ago

People

(Reporter: myk, Assigned: Dolske)

Tracking

({regression, relnote})

Trunk
mozilla1.9beta5
regression, relnote
Points:
---
Bug Flags:
blocking1.9 +

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
I recently changed my password on bugzilla.mozilla.org, but when I delete the old one and replace it with the new one in the Password field when logging into the site via its login form <https://bugzilla.mozilla.org/index.cgi?GoAheadAndLogIn=1>, Firefox doesn't update my saved password to reflect the change.

Steps to Reproduce:

1. make sure Firefox is storing your username and password for b.m.o.;
2. change your password <https://bugzilla.mozilla.org/userprefs.cgi?tab=account>;
3. log out of b.m.o;
4. log in using your new password <https://bugzilla.mozilla.org/index.cgi?GoAheadAndLogIn=1>;
6. log out again and then try to log back in without entering your new password into the Password field.

Expected Results: you can log in.

Actual Results: b.m.o complains that your username or password is incorrect.
(Reporter)

Updated

9 years ago
Summary: Firefox won't updated my saved bugzilla.mozilla.org password → Firefox won't update my saved bugzilla.mozilla.org password
(Assignee)

Comment 1

9 years ago
In error console:

Error: aNotifyBox is not defined
Source File: file:///Applications/Minefield.app/Contents/MacOS/components/nsLoginManagerPrompter.js
Line: 749

Hmm, the arg name in _showChangeLoginNotification() should be |aNotifyBox|, not |notifyBox|. None of the patches in bug 408797, where this code was added, would have worked due to this. Ehsan, did you not test any of your patches?!
Assignee: nobody → dolske
Blocks: 408797
Flags: blocking-firefox3?
Keywords: regression
OS: Linux → All
Hardware: PC → All
Summary: Firefox won't update my saved bugzilla.mozilla.org password → Firefox won't prompt to change stored passwords
Target Milestone: --- → Firefox 3
(Assignee)

Comment 2

9 years ago
Created attachment 307438 [details] [diff] [review]
Patch v.1

This fixes the now-obvious problem, and a quick run through changing a password seems to work fine now. I'll ask for review tomorrow after I've had some sleep and can test it some more, lest the irony police get after me. :-)
(Assignee)

Updated

9 years ago
Priority: -- → P1
Flags: blocking-firefox3? → blocking-firefox3+
Priority: P1 → P2
(In reply to comment #1)
> Hmm, the arg name in _showChangeLoginNotification() should be |aNotifyBox|, not
> |notifyBox|. None of the patches in bug 408797, where this code was added,
> would have worked due to this. Ehsan, did you not test any of your patches?!

Hmmm, I swear I got this running at first.  I must have made a mistake in the initial version of the patch, and then this lead astray... :-(  Sorry for the problem.

I think this should block Beta 4, because this breaks a functionality which users may rely upon.
Status: NEW → ASSIGNED
Target Milestone: Firefox 3 → Firefox 3 beta4
Comment on attachment 307438 [details] [diff] [review]
Patch v.1

Asking gavin for review on behalf of dolske.  This should be pretty easy to review.
Attachment #307438 - Flags: review?(gavin.sharp)
Keywords: relnote
(In reply to comment #3)
> I think this should block Beta 4, because this breaks a functionality which
> users may rely upon.

We'll relnote it. We're not gonna respin for this.
Target Milestone: Firefox 3 beta4 → Firefox 3
(In reply to comment #5)
> (In reply to comment #3)
> > I think this should block Beta 4, because this breaks a functionality which
> > users may rely upon.
> 
> We'll relnote it. We're not gonna respin for this.

How about having it in Beta 5 then?
Target Milestone: Firefox 3 → Firefox 3 beta5
Of course we'll take it in beta 5.
Attachment #307438 - Flags: review?(gavin.sharp) → review+
(Assignee)

Comment 8

9 years ago
(In reply to comment #4)

> Asking gavin for review on behalf of dolske.  This should be pretty easy to
> review.

Uhm, as I said in comment 2, I hadn't requested review yet because I did only cursory testing. Given that the original code was never tested, it's unknown if there are any other lurking problems. The point wasn't that the patch was hard to review, but that there's no sense in reviewing something that's not known to be a complete fix.
It doesn't hurt to get formal review on the change that we know we'll need to take, even if it isn't necessarily sufficient on it's own. Should still test and make sure everything's working, of course.
(Assignee)

Comment 10

9 years ago
Comment on attachment 307438 [details] [diff] [review]
Patch v.1

Ok, did some testing of saving and changing logins to exercise the various code paths here, and didn't see any other lurking problems.
Attachment #307438 - Flags: approval1.9?
Comment on attachment 307438 [details] [diff] [review]
Patch v.1

Blocker, doesn't need approval.
Attachment #307438 - Flags: approval1.9?
(Assignee)

Comment 12

9 years ago
Checking in toolkit/components/passwordmgr/src/nsLoginManagerPrompter.js;
  new revision: 1.30; previous revision: 1.29
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
(Reporter)

Comment 13

9 years ago
In yesterday's and today's post-checkin nightlies (f.e. Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b5pre) Gecko/2008031004 Minefield/3.0b5pre), Firefox continues not to prompt me to change b.m.o's stored password.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 14

9 years ago
Hmm, WFM. Maybe you're running into something else? Output from http://wiki.mozilla.org/Firefox:Password_Manager_Debugging would be helpful, or just track me down in the office today. :)
(Reporter)

Comment 15

9 years ago
(In reply to comment #14)
> Hmm, WFM. Maybe you're running into something else? Output from
> http://wiki.mozilla.org/Firefox:Password_Manager_Debugging would be helpful, or
> just track me down in the office today. :)

I tracked Justin down, and he helped me figure out that it was because b.m.o was on the list of sites that should not save my password.  I don't recall putting it on that list, but perhaps it was a while ago (but after it had already saved a password).

In any case, removing it from that list solved the problem, so this bug is indeed fixed, even though ironically it wasn't the problem I was experiencing.
Status: REOPENED → RESOLVED
Last Resolved: 9 years ago9 years ago
Resolution: --- → FIXED
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.