autosubscribe problems with two news servers on the same host.

NEW
Unassigned

Status

MailNews Core
Networking: NNTP
18 years ago
6 years ago

People

(Reporter: (not reading, please use seth@sspitzer.org instead), Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

lookin at nsNntpService::GetProtocolForUri() I can see we are going to have
problems with this:


create a new profile, run these two urls:

news://foo/bar
snews://foo/cheese

I think you'd end up with bar and cheese on one unsecure news server, foo

but, if you di news://foo/bar and snews://foo2/cheese, it would do the right
thing.  (bar on unsecure news server foo, cheese on secure news server foo2)

I think similiar problems would happen with the port

news://foo/bar
news://foo:2000/goat
news://foo:1000/cheese

all three newsgroups would end up under one server, instead of three.

Updated

18 years ago
QA Contact: lchiang → huang
moving to m20, accepting.
Status: NEW → ASSIGNED
Target Milestone: --- → M20
QA Contact: huang → stephend
OS: Windows NT → All
Hardware: PC → All
Product: Browser → Seamonkey

Updated

13 years ago
Assignee: sspitzer → mail
Status: ASSIGNED → NEW

Updated

9 years ago
Component: MailNews: Subscribe → MailNews: Message Display
QA Contact: stephend → search
Priority: P3 → --
This bug is being marked EXPIRED as it has seen no activity in a very long time.

If you think that the issue reported might still be relevant, please test with a recent release of SeaMonkey and if the problem persists feel free to re-open the report. Thank you.

http://www.seamonkey-project.org/
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → EXPIRED
This bug is being marked EXPIRED as it has seen no activity in a very long time.

If you think that the issue reported might still be relevant, please test with a recent release of SeaMonkey and if the problem persists feel free to re-open the report. Thank you.

http://www.seamonkey-project.org/
Time doesn't stop this still being an issue.
Status: RESOLVED → REOPENED
Resolution: EXPIRED → ---
Assignee: mail → nobody
QA Contact: search → message-display
Status: REOPENED → UNCONFIRMED

Comment 5

7 years ago
This is still an issue, with various dupes around!
Status: UNCONFIRMED → NEW
Component: MailNews: Message Display → Backend
Ever confirmed: true
Product: SeaMonkey → MailNews Core
QA Contact: message-display → backend

Updated

6 years ago
Component: Backend → Networking: NNTP
QA Contact: backend → networking.nntp
Summary: autosubscribe problems with two servers on the same host. → autosubscribe problems with two news servers on the same host.
You need to log in before you can comment on or make changes to this bug.