Independent windows/tabs should not interfere with each other (block, starve)

RESOLVED DUPLICATE of bug 384323

Status

()

Core
Layout
RESOLVED DUPLICATE of bug 384323
10 years ago
10 years ago

People

(Reporter: BenB, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
I routinely have several browser windows open, each with several tabs.
Nevertheless, I sometimes come into situation where one window content makes the whole browser practically unusable.

Either it responds too slowly (because another page that's currently rendering or doing JS stuff uses all of CPU) or the page does not come in from the net (because some other page triggered so many network connections that the browser is at the absolute or per-server max).

User visible effects (examples):
The CPU is mainly a problem for me on the 3 year old PowerBook G4, and if a site tries to do 3D in JS and similar stuff.
I run into the absolute network connections limit once in a while, esp. when a certain server or network is not responding and/or a page loads many images. The user effects are very irritating, because the browser / whole network connection seems to be broken, although it's just one server/network.

The user assumes that independent windows don't influence each other (most users have no concept of a running "process", just "window"). I would define pages to be "independent" when neither keeps JS or DOM references to the other, but 2 pages from the same domain/host are 'independent'.
(However, to improve on that, the host could be considered in the resource allocation, so that one host cannot open 50 pages (manually by user or deliberately automatic by site), leaving only 1/51 of the resources for the other page from another domain that the user tries to view.)

If 2 windows or tabs are independent from each other, neither should be able to starve the other from CPU/net/RAM resources, but they should be divided equally.

This is a replacement of bug 40848, which Brendan Eich rightfully critized to imply a solution, not a problem. I think the problem does exist, though, and should be solved, no matter how.
(Reporter)

Comment 1

10 years ago
This bug is mostly covered by meta bug 384323 (UI responsiveness). I'll close this one and filed a more specific bug about the network connections problem: bug 421128.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 384323
You need to log in before you can comment on or make changes to this bug.