Closed Bug 421193 Opened 13 years ago Closed 13 years ago

label tag width ignored in page formatting

Categories

(Camino Graveyard :: Page Layout, defect)

PowerPC
macOS
defect
Not set
normal

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 9458

People

(Reporter: captain132, Unassigned)

References

()

Details

User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en; rv:1.8.1.12) Gecko/20080206 Camino/1.5.5
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en; rv:1.8.1.12) Gecko/20080206 Camino/1.5.5

The width of the label tag is ignored in page formatting both in and outside of forms. Check out the page layout in the above link in Camino and Safari. Safari is doing it right. This is the css for the label. 

label.form {
  display: inline-block;
  line-height: 1.4em;
  vertical-align: top;
  width: 150px;
  font-size:105%;
}


Reproducible: Always

Steps to Reproduce:
1. just visit the page
2. http://dashboard.oemscripts.com/contact.php
3.
Actual Results:  
misaligned formatting

Expected Results:  
proper formatting

Works properly with Safari 3.0.4, Opera 9.26, Explorer 5.2.3
Fails with Camino 1.5.5, Netscape Navigator 7.1
Gecko 1.8 - the rendering engine used by Camino 1.5 (and 1.6b) and Firefox 2 - does not support 'display:inline-block'. The element defaults to its default value, inline. 'width' does not apply to inline elements.

Gecko 1.9 (Fx 3, Camino 2a) does support 'display:inline-block' correctly.
Status: UNCONFIRMED → RESOLVED
Closed: 13 years ago
Resolution: --- → WORKSFORME
Resolution: WORKSFORME → DUPLICATE
Duplicate of bug: inline-block
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.