Closed Bug 421212 Opened 12 years ago Closed 12 years ago

assertion dialog when importing bookmarks file

Categories

(Firefox :: Bookmarks & History, defect, P2)

x86
macOS
defect

Tracking

()

RESOLVED WORKSFORME
Firefox 3 beta5

People

(Reporter: jbecerra, Assigned: dietrich)

Details

Attachments

(1 file)

While testing Fx3b4rc1 I exported my default bookmarks to a file. Then I imported the bookmarks file using the Import and Backup button in Library. I was presented with the beachball before getting a little assertion dialog. See image.

STR:
1. Install Fx3b4 or latest and export the default bookmarks to a file.
2. Go the Bookmarks and Show All Bookmarks
3. Click on Import and Backup and try to import the bookmarks file from step 1.

Expected: After the import you should be able to navigate through the imported bookmarks in the Library window.

Actual: Funkiness and an assertion dialog. See image.
Flags: blocking-firefox3?
Flags: blocking-firefox3? → blocking-firefox3+
Priority: -- → P2
Text from screenshot (to make dupe finding easier)

Assertion Failed
ASSERT: null node
0:PU_nodelsContainer(undefined)
1:PTV_isContainer(3)
Assignee: nobody → dietrich
Target Milestone: --- → Firefox 3 beta5
Juan, was this reproducible using the default bookmarks set? I'm not able to to reproduce with a clean profile, nor with my bookmarks.

Can you provide the bookmarks HTML file that exhibited the problem, either on the bug or to me privately?
I experienced this problem using an bookmarks file I had exported earlier using the latest nightly, but it wasn't the default bookmarks set. I'm trying to reproduce the problem now, on the profile I was using during testing, but I don't see the problem. I'll keep trying.
I'm having problems reproducing this problem, now. It's likely that the browser was in a really bad state when I ran into this problem (and also the problem in bug 421246), because I cannot reproduce either. I will now try running the places test suite, which may have gotten me in that state.
marking WFM and clearing blocking flag due to reporter not able to reproduce.

please reopen/renom if you find STR.
Status: NEW → RESOLVED
Closed: 12 years ago
Flags: blocking-firefox3+
Resolution: --- → WORKSFORME
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.