Getting 2 context menus when right-clicking on Flash plugin

RESOLVED FIXED in mozilla1.9beta5

Status

()

Core
Plug-ins
P1
normal
RESOLVED FIXED
10 years ago
10 years ago

People

(Reporter: Martijn Wargers (dead), Assigned: mats)

Tracking

({regression})

Trunk
mozilla1.9beta5
x86
Windows XP
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
Created attachment 307627 [details]
testcase

See the url, when right-clicking on the Flash plugin, I get 2 context menus, one from the Flash plugin and one from the Mozilla context menu.

This seems to have regressed when bug 389931 got fixed.

I can also reproduce it with the testcase, but only sporadically. Not sure how to trigger the bug with the testcase. Try reloading a few times or something. But with the url, I can reproduce it always.

Jst was just talking in bug 420886, comment 9, something that might be related to this?
Flags: blocking1.9?

Comment 1

10 years ago
Confirming here. I have been experiencing the same issue, any flash plugin animation menu seems to be working very weirdly, often opening 2 context menus and often one is not able to select anything from any of the 2 menus.
No right-click weirdness: 20080226_0310_firefox-3.0b4pre.en-US.win32
Yes right-click weirdness: 20080226_0557_firefox-3.0b4pre.en-US.win32
Checkins to module PhoenixTinderbox between 2008-02-26 03:10 and 2008-02-26 05:57 :
http://bonsai.mozilla.org/cvsquery.cgi?treeid=default&module=PhoenixTinderbox&branch=HEAD&branchtype=match&dir=&file=&filetype=match&who=&whotype=match&sortby=Date&hours=2&date=explicit&mindate=2008-02-26+03%3A10&maxdate=2008-02-26+05%3A57&cvsroot=%2Fcvsroot
More easily reproduced for me using youtube, eg: http://www.youtube.com/watch?v=59ZX5qdIEB0

Comment 3

10 years ago
Another related(I think) effect of that regression is that the whole events catching is even messing with the window level(at least on WinXP):
1.load plenty of pages with flash content, especially those that catch mouse input, in multiple windows with multiple tabs
2.open a few new blank window
3.go in the windows taskbar, right click on any of the new blank window
4.try to click on "close (alt+f4)" in the menu

Expected result: the click event is correctly sent to windows, and the windows is closed
Actual result: rather randomly, roughly 80% of the time here, the click event doesn't get through and nothing happens, the menu stays up. Repetitively clicking eventually works, but is far from working correctly.

Posting this here since it only happens with multiple flash videos loaded here, and in a very similar way to the context menu issue(which also has the problem that one must repetitively click on the menu option wanted until the event goes through)

Comment 4

10 years ago
Just posting to confirm that the regression range is exactly the same for my last post as the one that stevee posted before.
Seems like a bad regression, blocking, P1, we should get this in for a beta to make sure we get a lot of testing for the fix.
Assignee: nobody → mats.palmgren
Flags: blocking1.9? → blocking1.9+
Priority: -- → P1

Comment 6

10 years ago
I'm not getting two context menus when I right click the flash movie, but what I am getting is when I right click somewhere away from the flash movie, and then right click on the flash movie, the first context menu doesn't go away.
(Assignee)

Comment 7

10 years ago
(In reply to comment #6)
> when I right click somewhere away from the flash movie, and
> then right click on the flash movie, the first context menu doesn't go away.

That's a different problem which also occurs in Firefox 2.  Please file
a separate bug (if not done already) in Core:Plug-ins.
(Assignee)

Comment 8

10 years ago
The original problem should be fixed by bug 420148.  There are test builds
available at:
https://build.mozilla.org/tryserver-builds/2008-03-12_21:46-mpalmgren@mozilla.com-420148_wip3/
Depends on: 420148

Comment 9

10 years ago
(In reply to comment #7)
> (In reply to comment #6)
> > when I right click somewhere away from the flash movie, and
> > then right click on the flash movie, the first context menu doesn't go away.
> 
> That's a different problem which also occurs in Firefox 2.  Please file
> a separate bug (if not done already) in Core:Plug-ins.
> 

Yeah, sorry about that, that is Bug 294688.
Removing blocking+ as it sounds like the critical part of this is being fixed in bug 420148. Please re-nominate if it turns out to not be so...
Flags: blocking1.9+
(Assignee)

Comment 11

10 years ago
Fixed by bug 420148.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.9beta5
(Assignee)

Updated

10 years ago
Duplicate of this bug: 422901
(Assignee)

Updated

10 years ago
Duplicate of this bug: 424474
Duplicate of this bug: 424397
You need to log in before you can comment on or make changes to this bug.