Location (Awesome) Bar lets you scroll right & left

VERIFIED DUPLICATE of bug 406373

Status

()

VERIFIED DUPLICATE of bug 406373
11 years ago
11 years ago

People

(Reporter: dev, Unassigned)

Tracking

Trunk
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

11 years ago
Created attachment 307672 [details]
Start here

Build identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9b5pre) Gecko/2008030504 Minefield/3.0b5pre

Using my mouse to scroll up and down the awesome bars results, produces an unwanted after-effect that allows me to also scroll right and then left. In some cases it will even lock on a completely empty result menu and won't let me scroll back to the left. (See screenshots)

Steps to reproduce a reversible effect (Scenario A):
1. Type something to make your awesome bar produce a whole bunch of results.
2. Scroll down, then scroll to the right! (Once you scroll down, don't let your mouse high-light another item in the results menu! that will ruin the reproduction)
3. Scroll back to the left to see your results.

Steps to reproduce an irreversible effect (Scenario B):
1. Type something to make your awesome bar produce a whole bunch of results.
2. Scroll down, then scroll to the right! (Once you scroll down, don't let your mouse high-light another item in the results menu! that will ruin the reproduction)
3. Now, after you scrolled all the way to the right and your results menu goes completely blank, hover over another item to high-light it, then try to scroll back left.


Expected result for both scenarios:
Menu should not let you scroll to the right at all!
(Reporter)

Updated

11 years ago
Summary: Location (Awesome) Bar let's you scroll right & left → Location (Awesome) Bar lets you scroll right & left
(Reporter)

Comment 1

11 years ago
Created attachment 307673 [details]
Step #2
(Reporter)

Comment 2

11 years ago
Created attachment 307674 [details]
Voilla!
This is bug 406373, isn't it?
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 406373
(Reporter)

Comment 4

11 years ago
Ahhh I have literally looked for 15m for this bug and couldn't find any! Sorry about that...
(In reply to comment #4)
> Ahhh I have literally looked for 15m for this bug and couldn't find any! Sorry
> about that...

No worries; just making sure (although post-facto[!]); verified per your concession :-P
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.