auto-detection of character encoding incorrectly picks Chinese for BBC 606 pages with pound (£) signs

RESOLVED DUPLICATE of bug 177505

Status

()

RESOLVED DUPLICATE of bug 177505
11 years ago
11 years ago

People

(Reporter: sexyeuroboy, Unassigned)

Tracking

unspecified
Points:
---
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; SunOS sun4v; en-GB; rv:1.8.1.11) Gecko/20071205 Firefox/2.0.0.11
Build Identifier: Mozilla/5.0 (X11; U; SunOS sun4v; en-GB; rv:1.8.1.11) Gecko/20071205 Firefox/2.0.0.11

With Character Encoding set to Auto-Detect -> Universal, pages on the BBC Sport message board are misidentified as being gb18030 instead of windows-1252 if the page contains any pound (£) characters. See the given URL. While it'd be better if the site were explicit in its encoding, auto-detect shouldn't be getting this wrong.

Reproducible: Always

Steps to Reproduce:
1. Set character encoding to universal autodetection using View -> Character Encoding - > Auto-Detect -> Universal.
2. Visit a page on the BBC 606 message board which contains £ figures.
Actual Results:  
Page is detected and rendered as gb18030, and strings starting with a £ sign are rendered as �.

Expected Results:  
Page is detected and rendered as windows-1252 or appropriate and £ signs are shown normally.
This bug is already fixed in the betas of Firefox 3.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 177505
Flags: in-testsuite+
You need to log in before you can comment on or make changes to this bug.