Website crashes Minefield

RESOLVED DUPLICATE of bug 419127

Status

()

Core
General
--
critical
RESOLVED DUPLICATE of bug 419127
10 years ago
10 years ago

People

(Reporter: FirasE, Unassigned)

Tracking

({crash})

Trunk
x86
Windows XP
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b5pre) Gecko/2008030607 Minefield/3.0b5pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b5pre) Gecko/2008030607 Minefield/3.0b5pre

Minefield loads the page, pauses/freezes for a minute, then the crash box appears (Send/Don't Send report). Also happens under Minefield Safe Mode.

Reproducible: Always

Steps to Reproduce:
1. Visit http://sports.yahoo.com/golf/pga/news?slug=ap-golfer-birdkilled&prov=ap&type=lgns

Actual Results:  
Minefield crashes

Expected Results:  
No crash
confirmed with Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.9b5pre) Gecko/2008030607 Minefield/3.0b5pre, i also crash and breakpad does not fire.

Out from windbg

(110c.3ec): Access violation - code c0000005 (first chance)
First chance exceptions are reported before any exception handling.
This exception may be expected and handled.
eax=00000000 ebx=04300000 ecx=00000003 edx=ffffffff esi=00000003 edi=ffffffff
eip=7d61f185 esp=0012f40c ebp=0012f418 iopl=0         nv up ei pl zr na pe nc
cs=0023  ss=002b  ds=002b  es=002b  fs=0053  gs=002b             efl=00010246
ntdll32!RtlEnterCriticalSection+0x19:
7d61f185 f00fb301        lock btr dword ptr [ecx],eax ds:002b:00000003=????????
0:000> kp
ChildEBP RetAddr  
0012f418 60006c30 ntdll32!RtlEnterCriticalSection+0x19
WARNING: Stack unwind information not available. Following frames may be wrong.
0012f428 60007b30 MOZCRT19+0x6c30
0012f4fc 60b3938c MOZCRT19+0x7b30
0012f51c 601137a9 xul+0x68938c
0012f5e8 60120cdf js3250+0x137a9
0012f764 6011387c js3250+0x20cdf
0012f82c 60105206 js3250+0x1387c
0012f86c 60122283 js3250+0x5206
0012f93c 600cb2c9 js3250+0x22283
0012f97c 60534066 nspr4+0x1b2c9
0012f9ac 604d31aa xul+0x84066
00000000 00000000 xul+0x231aa
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: crash
Version: unspecified → Trunk

Comment 2

10 years ago
No crash for me on Mac.

Tomcat, can you get a stack trace using a debug build?
Component: General → General
Product: Firefox → Core
QA Contact: general → general

Comment 3

10 years ago
that basically means a null lock, did you forget to use sympath/symfix?

jesse: we don't need debug builds, we only need symbols to be properly configured (which they usually are...).

Comment 4

10 years ago
Do the people crashing have Yahoo Messenger installed?  This may be Bug 419127.  
Created attachment 307955 [details]
better stracktrace

oh sorry timeless and Jesse, here is a better stacktrace.

(In reply to comment #4)
> Do the people crashing have Yahoo Messenger installed?  This may be Bug 419127. 
> 

Yes, Yahoo Messenger is installed, so it might be really a dupe of bug 419217
(In reply to comment #5)
> Yes, Yahoo Messenger is installed, so it might be really a dupe of bug 419217
> 
Err make this Bug 419127 :-/

Updated

10 years ago
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 419127
You need to log in before you can comment on or make changes to this bug.