On tr_new_run.cgi, Ajax driven fields do not revalidate after a manual change

RESOLVED INVALID

Status

Testopia
Test Runs
--
minor
RESOLVED INVALID
10 years ago
10 years ago

People

(Reporter: Steven Ginn, Assigned: Greg Hendricks)

Tracking

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.12) Gecko/20080201 Firefox/2.0.0.12
Build Identifier: 

Since the Ajax fields have some lag, this leads to possible errors in data specified.

Reproducible: Always

Steps to Reproduce:
1. Create a new test run for any test plan
2. Select one or more test cases
3. In the DropDown combo boxes for Product Version, Run Manager, Build, or Environment, select one of the valid entities.
4. Type in one of the boxes to make it an invalid entry
5. Click Submit
Actual Results:  
The test run will be created with the last valid selection for each drop down.

Expected Results:  
Should get an error saying the specified selections are invalid.

Flagging this as Minor, since there is a workaround which would be to modify the invalid settings after creation, or to delete the test run and start over.
(Assignee)

Comment 1

10 years ago
Actually, this is by design. It will automatically create the build or environment that you type so you don't have to go to a different screen to create one before adding it to a run.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.