Closed Bug 421605 Opened 13 years ago Closed 13 years ago

when 'always show tab bar' is enabled, cmd + w does not close the last tab which means you can't close the window

Categories

(Firefox :: Tabbed Browser, defect)

PowerPC
macOS
defect
Not set
normal

Tracking

()

VERIFIED DUPLICATE of bug 348031

People

(Reporter: patrick, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9b3) Gecko/2008020511 Firefox/3.0b3
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9b3) Gecko/2008020511 Firefox/3.0b3

When the option 'always show tab bar' is enabled you are unable to close the main browser window with cmd+w as you can do with older releases. You can close all the tabs except for the last one which means you have to manually close the window instead of using a keyboard shortcut to do so.

Reproducible: Always

Steps to Reproduce:
1. Enable 'always show tab bar'
2. open tabs
3. try to close all the tabs using command+w and then try and close the last one, closing the window. It doesn't work
Actual Results:  
You find yourself unable to close the main window with a keyboard shortcut without quitting the application

Expected Results:  
it should have closed the main window, as it does when the tab bar isn't always displayed
This was fixed after Firefox 3 Beta 3 in bug 348031.  FWIW, even if it hadn't been fixed, you would have been able to close the window with Cmd+Shift+W.
Status: UNCONFIRMED → RESOLVED
Closed: 13 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 348031
Verified dup
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.