fx dialog checkboxes and radios positioned too high

VERIFIED FIXED in mozilla1.9beta5

Status

()

VERIFIED FIXED
11 years ago
10 years ago

People

(Reporter: tuukka.tolvanen, Assigned: dbaron)

Tracking

Trunk
mozilla1.9beta5
x86
Linux
Points:
---
Bug Flags:
blocking1.9 -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

11 years ago
Created attachment 308214 [details]
screenshot

linux firefox trunk 2008-03-08-00Z

I guess this would be due to bug 402940, don't know whether to blame core, or theme for possibly assuming something wrong, picking one at random :)
Component: Theme → Layout: Form Controls
Product: Firefox → Core
QA Contact: theme → layout.form-controls
Flags: blocking1.9?
Possible it's a theme issue, but I'm going to guess Core issue for now.

Comment 2

11 years ago
dbaron, is there anything you need to change in XUL code to get this working? Because the controls were aligned perfectly in XUL before so I assume some kind of hack was used.

Comment 3

11 years ago
So whats happening now is that the radios and checkboxes are being drawn at the top of the frame they are given. vertical-align: middle doesn't work, but I imagine there might be some XUL magic to get it working...
And guess what, the assertion that I put in in that patch was firing, to show exactly what the problem was.

Patch shortly.
Assignee: nobody → dbaron
Created attachment 308242 [details] [diff] [review]
patch
Attachment #308242 - Flags: superreview?(roc)
Attachment #308242 - Flags: review?(ventnor.bugzilla)

Comment 6

11 years ago
Comment on attachment 308242 [details] [diff] [review]
patch

/me hunts a crow to eat
Attachment #308242 - Flags: review?(ventnor.bugzilla) → review+
Component: Layout: Form Controls → Widget: Gtk
QA Contact: layout.form-controls → gtk
Attachment #308242 - Flags: superreview?(roc) → superreview+
Comment on attachment 308242 [details] [diff] [review]
patch

bad regression from a patch that landed a few days ago, just reverts a tiny part of that patch
Attachment #308242 - Flags: approval1.9?
Marking this as wanted1.9.0.x as well as approving the patch.  
Flags: wanted1.9.0.x+
Flags: blocking1.9?
Flags: blocking1.9-
Comment on attachment 308242 [details] [diff] [review]
patch

a1.9+=damons
Attachment #308242 - Flags: approval1.9? → approval1.9+
Fix checked in to trunk, 2008-03-12 15:03 -0700.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.9beta5
(Reporter)

Comment 11

11 years ago
v trunk 2008051611
Status: RESOLVED → VERIFIED
Flags: wanted1.9.0.x+
You need to log in before you can comment on or make changes to this bug.