Closed Bug 421882 Opened 14 years ago Closed 14 years ago

forced tab change w/cookie confirmation turned on

Categories

(Firefox :: Tabbed Browser, defect)

x86
Windows XP
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 405239

People

(Reporter: kalten+bugzilla, Unassigned)

Details

(Whiteboard: [DUPEME])

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b3) Gecko/2008020514 Firefox/3.0b3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b3) Gecko/2008020514 Firefox/3.0b3

If cookie confirmation is turned on (that is, on Tools -> Options -> Privacy, "Keep until:" is set to "Ask me every time") and you are using tabbed browsing, a cookie being set on a tab that is not active will cause the active tab to change to that tab, and THEN the cookie approval dialog is presented.

Reproducible: Always

Steps to Reproduce:
1.  Go to Tools -> Options and click on "Privacy"; make sure that "Accept cookies from sites" is marked, and "Keep until" is set to "Ask me every time".
2.  Open a set of sites in tabs.  Probably the easiest way (and the one most likely to reproduce this issue) is by using the "Open All in Tabs" context menu option for a bookmarks folder.  Make sure that you choose pages that *will* set cookies, and that the sites aren't in your blacklist.  (The set of URLs I use is in the "Additional Information" field.)
Actual Results:  
The tab for a site which wishes to set a cookie immediately becomes the active tab, and the cookie approval dialog is presented.

Expected Results:  
The cookie approval dialog should not be presented until the user switches to the appropriate tab.  Doing otherwise takes control away from the user.

This behavior appears to have been introduced in the FF3 betas.

The set of URLs I use to reproduce this bug is:
http://www.groklaw.net/staticpages/index.php?page=Headlines
http://www.kuro5hin.org/
http://slashdot.org/
http://thedailywtf.com/Default.aspx
http://www.theregister.co.uk/
Dupe of Bug 405239 ? Although, there is at least one older similar confirmed bug but I can't find it atm.
Whiteboard: [DUPEME]
After looking at the description, it may very well be; the symptoms for Bug 405239 are similar, even though the steps to reproduce are somewhat different.  (How that didn't come up when I was searching for bugs, I've no idea.)

In any event, I like the suggestion made by the submitter of Bug 405239; it's certainly a more elegant solution than a modal dialog box.
Sure.  If you find the older bug, you can always go back and mark bug 405239 as a dup of it ;)
Status: UNCONFIRMED → RESOLVED
Closed: 14 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 405239
You need to log in before you can comment on or make changes to this bug.