Closed Bug 421928 Opened 13 years ago Closed 13 years ago

Gzip'd SQL dump files are saved wrong (is cleartext instead of .gz hence the .sql.gz extension)

Categories

(Core Graveyard :: File Handling, defect)

x86
Windows Vista
defect
Not set
major

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 233047

People

(Reporter: stormbringer1971, Unassigned)

Details

(Keywords: regression)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; de; rv:1.9b4) Gecko/2008030714 Firefox/3.0b4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; de; rv:1.9b4) Gecko/2008030714 Firefox/3.0b4

I experience the following problem in all builds of Firefox 3.0 up to the currently installed version 3.0 beta4 rc2

Whenever I try to receive a Gzip'd SQL dump in phpMyAdmin, Firefox writes a NON-Gzip'd file onto the hard drive upon download. Although the filename carries a .sql.gz extension the content of the file is not compressed in any way. When opened in Windows' notepad.exe it shows up as clear text instead as a compressed "binary".

Also, the filesize doesn't match to the file I get by using Firefox 2.0.0.12 (which is a proper .sql.gz file) ...

Gzip'd SQL dump saved with fx2: ~10MB
Gzip'd SQL dump saved with fx3: ~44,5MB

Apart from Firefox 2.0.0.12 I also checked against IE7, IE8b1 and Opera 9.26, and all these browsers don't have that problem.

I think someone should take a look into this problem as some users in the mozillazine forum confirmed my problem.


Reproducible: Always

Steps to Reproduce:
1. Log in at a host running phpMyAdmin
2. Select "Export" in the main page
3. Select a Database, set the export options
4. Set "Save as file" to "gzipped" and click "Go" to receive the SQL dump
Actual Results:  
A cleartext, non-gzipped file, was retrieved

Expected Results:  
A gzipped file
Keywords: regression
Component: Download Manager → File Handling
Product: Firefox → Core
QA Contact: download.manager → file-handling
Whiteboard: DUPEME
Version: unspecified → Trunk
Dupe of bug 233047?
Yes
Status: UNCONFIRMED → RESOLVED
Closed: 13 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 233047
Whiteboard: DUPEME
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.