Closed Bug 421997 Opened 12 years ago Closed 12 years ago

Crash [@ nsXBLBinding::EnsureScriptAPI] with XBL constructor that throws and onerror handler

Categories

(Core :: XBL, defect, critical)

x86
macOS
defect
Not set
critical

Tracking

()

RESOLVED FIXED

People

(Reporter: jruderman, Unassigned)

References

(Blocks 2 open bugs)

Details

(4 keywords)

Crash Data

Attachments

(1 file)

Loading the testcase triggers:

###!!! ASSERTION: You can't dereference a NULL nsRefPtr with operator->().: 'mRawPtr != 0', file ../../../dist/include/xpcom/nsAutoPtr.h, line 1083

Crash [@ nsXBLBinding::EnsureScriptAPI]
We have null pointers in mAttachedStack.
This is a regression from bug 401463.  We need to either add a nullcheck or reland bug 401155 (which removes the offending code).  That one is blocking, so that's probably what will fix this...
Blocks: 401463
Depends on: 401155
Flags: blocking1.9?
Keywords: regression
Not a blocker since it's a null-pointer dereference. It should also be fixed by now since bug 401155 is checked in. Not marking fixed yet though as that bug still has bad regressions.
Flags: blocking1.9? → blocking1.9-
FIXED by checkin for bug 401155
Status: NEW → RESOLVED
Closed: 12 years ago
Flags: in-testsuite?
Resolution: --- → FIXED
Crashtest checked in.
Flags: in-testsuite? → in-testsuite+
Crash Signature: [@ nsXBLBinding::EnsureScriptAPI]
You need to log in before you can comment on or make changes to this bug.