Unable to use "up" and "down" arrows on the keypad to go to the beginning and end of single-line text fields

RESOLVED DUPLICATE of bug 231754

Status

()

Firefox
Keyboard Navigation
RESOLVED DUPLICATE of bug 231754
10 years ago
10 years ago

People

(Reporter: Rene Malenfant, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.4; en-US; rv:1.9b4) Gecko/2008030317 Firefox/3.0b4
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.4; en-US; rv:1.9b4) Gecko/2008030317 Firefox/3.0b4

Unable to use "up" and "down" arrows on the keypad to go to the beginning and end of single-line text fields

I am rather sure Firefox used to be able to do this until some point in the 2.0 line.


For example, on this bug submission form.  I can use the up and down arrows on my keyboard to navigate the "details" box, and if I keep hitting the up key, it will eventually take me to the upper-left corner of the box.  If I keep hitting the down key, the cursor ends up after the last character on the last line of text.  Makes sense.  That's the way I like it.

However.  It is *impossible* to navigate single-line text fields (i.e., the "Summary" box on this bug submission form) in the same manner.  Pressing the up arrow and down arrow when the cursor is in the summary box does ABSOLUTELY NOTHING.


Reproducible: Always

Steps to Reproduce:
1. Place the cursor in a single-line text field, such as the "Summary" field of this bug submission form.
2. Hit the up or down arrow on the keyboard.

Actual Results:  
Nothing.


Expected Results:  
Like almost every other browser and text editor I have ever used (and to be consistent with Firefox's behaviour in multi-line text fields), I expect the cursor to go to the left-hand side of the field when I hit "up".


If you don't understand what I'm talking about, just try it again using Safari.

Safari's behaviour in this situation is about a million times more convenient.  (i.e., if I want to select all of the text in a single-line text field with Safari, I just hit "Shift + Up".  But to accomplish the same thing with Firefox, I need to hit "Shift + Left, Left, Left, Left, Left, Left, Left, Left..."

Comment 1

10 years ago
Fixed in Firefox 3 :)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 231754
You need to log in before you can comment on or make changes to this bug.