Closed Bug 422203 Opened 13 years ago Closed 12 years ago

Find bar focus ring color doesn't respect OS setting

Categories

(Toolkit :: Themes, defect, P2)

All
macOS
defect

Tracking

()

VERIFIED FIXED
mozilla1.9.2a1

People

(Reporter: me, Assigned: dao)

References

Details

(Keywords: polish, verified1.9.1, Whiteboard: [polish-easy] [polish-visual] [polish-p1])

Attachments

(1 file, 1 obsolete file)

User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9b4) Gecko/2008030317 Firefox/3.0b4
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9b4) Gecko/2008030317 Firefox/3.0b4

My OS "Appearance" setting is set to graphite.  The location bar should display a gray ring around it when it has focus.  The default theme always displays a blue ring.

Reproducible: Always

Steps to Reproduce:
1. Press Cmd-L
Actual Results:  
Location bar displays a blue ring.

Expected Results:  
Location bar displays a gray ring.
Interestingly enough, this works when I have focus around the bugzilla text box I am writing in right now. But I see that the location bar does continue to have the blue highlight even after I switch to graphite. Confirming using Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9b5pre) Gecko/2008031104 Minefield/3.0b5pre.
Status: UNCONFIRMED → NEW
Ever confirmed: true
This has been reported several times in hendrix and I've come across a few blog posts mentioning this issue. It's apparently specific to chrome. 
Flags: blocking-firefox3?
I was pretty sure that there was a dupe out there, but I agree that this needs to be fixed.

Kevin: I think we can do without the highlight on the location bar and the search bar, if worst comes to worst. The fact that it doesn't follow the selected OS colouring is pretty jarring, especially since the form widgets get it properly from cocoa.
Flags: blocking-firefox3? → blocking-firefox3+
Priority: -- → P2
Assignee: nobody → mconnor
I think this is an issue for a number of chrome elements, like search fields, maybe tabs too.
Discussed with beltzner, not major enough to block, we'll clean up graphite when we can distinguish better.
Flags: blocking-firefox3+ → blocking-firefox3-
Assignee: mconnor → nobody
Depends on: 448767
Blocks: 458197
Hardware: Macintosh → All
Summary: Location bar focus color doesn't respect OS setting. → Location bar and search bar focus color doesn't respect OS setting.
Whiteboard: polish
Version: unspecified → Trunk
Summary: Location bar and search bar focus color doesn't respect OS setting. → Location bar, search bar, and find bar focus color doesn't respect OS setting
Depends on: 481382
I'm fixing the urlbar / searchbar part over in bug 481382.
Keywords: polish
Whiteboard: polish → [polish-easy] [polish-visual] [polish-high-visibility]
Morphing, since bug 481382 handles the nav bar.
Assignee: nobody → dao
Status: NEW → ASSIGNED
Depends on: 481853
No longer depends on: 448767, 481382
Summary: Location bar, search bar, and find bar focus color doesn't respect OS setting → Find bar focus ring color doesn't respect OS setting
Attached patch patch (obsolete) — Splinter Review
Attachment #366178 - Flags: review?(mconnor)
Component: Theme → Themes
Flags: blocking-firefox3-
Product: Firefox → Toolkit
QA Contact: theme → themes
Attachment #366178 - Attachment is obsolete: true
Attachment #366809 - Flags: review?(enndeakin)
Attachment #366178 - Flags: review?(mconnor)
Depends on: 476738
Comment on attachment 366809 [details] [diff] [review]
patch, updated to latest trunk

Seems to work ok, but I'm not really the right person for reviewing theme changes.
Attachment #366809 - Flags: review?(enndeakin) → review+
http://hg.mozilla.org/mozilla-central/rev/728119be8416
Status: ASSIGNED → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.9.2a1
Verified fixed with Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.2a1pre) Gecko/20090315 Minefield/3.2a1pre ID:20090315030726.

Is it something we can have on 1.9.1 after bug 476738 is fixed on branch?
Status: RESOLVED → VERIFIED
yes
Attachment #366809 - Flags: approval1.9.1?
Attachment #366809 - Flags: approval1.9.1? → approval1.9.1+
Comment on attachment 366809 [details] [diff] [review]
patch, updated to latest trunk

a191=beltzner
Keywords: checkin-needed
Verified fixed with Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1b4pre) Gecko/20090409 Shiretoko/3.5b4pre ID:20090409031809
This bug's priority relative to the set of other polish bugs is:
P1 - Polish issue that appears in the main window, or is something that the user may encounter several times a day.

effects the main window
Whiteboard: [polish-easy] [polish-visual] [polish-high-visibility] → [polish-easy] [polish-visual] [polish-p1]
You need to log in before you can comment on or make changes to this bug.