Closed Bug 422278 Opened 14 years ago Closed 14 years ago

Applet EntrustTruePass Applet problem

Categories

(Core :: Plug-ins, defect)

PowerPC
macOS
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 421855

People

(Reporter: shiaolon, Unassigned)

References

()

Details

User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9b4) Gecko/2008030317 Firefox/3.0b4
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9b4) Gecko/2008030317 Firefox/3.0b4

Error: uncaught exception: [Exception... "Failure"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: https://sportal.uspto.gov/authenticate/javascript/EntrustTruePassClientPrivate.js :: entrustTruePassPrivateRegisterApplet :: line 5"  data: no]

If using Safari 3.0.4 when visiting the same site, the window will bring up just fine.  

I have Java Embedding Plugin 0.9.6.3 installed and all of them are enabled.

application/x-java-vm 	Embedded JVM 	xjv 	Yes
application/x-java-applet 	Embedded Java Applet 	xja 	Yes
application/x-java-applet;version=1.1 	Embedded Java Applet 	xja11 	Yes
application/x-java-applet;version=1.1.1 	Embedded Java Applet 	xja111 	Yes
application/x-java-applet;version=1.1.2 	Embedded Java Applet 	xja112 	Yes
application/x-java-applet;version=1.1.3 	Embedded Java Applet 	xja113 	Yes
application/x-java-applet;version=1.2 	Embedded Java Applet 	xja12 	Yes
application/x-java-applet;version=1.2.1 	Embedded Java Applet 	xja121 	Yes
application/x-java-applet;version=1.2.2 	Embedded Java Applet 	xja122 	Yes
application/x-java-applet;version=1.3 	Embedded Java Applet 	xja13 	Yes
application/x-java-applet;version=1.3.1 	Embedded Java Applet 	xja131 	Yes
application/x-java-applet;version=1.4 	Embedded Java Applet 	xja14 	Yes
application/x-java-applet;version=1.4.1 	Embedded Java Applet 	xja141 	Yes
application/x-java-applet;version=1.4.2 	Embedded Java Applet 	xja142 	Yes
application/x-java-applet;version=1.5 	Embedded Java Applet 	xja15 	Yes



Reproducible: Always

Steps to Reproduce:
1. Go to the URL.
2. Click on "Browse" button.
3. A window should appears letting me choose where the file for the certification for the site.  But nothing happens and the error console displays the error message included in the "Details Section" above.


Expected Results:  
A dialogue window should appear.
Summary: Go to URL. Click on Browse should open a dialog window to find the file. But no window pops up and the error console displays the following message: → Applet EntrustTruePass Applet problem
I've confirmed this (on OS X 10.5.2), but only on the trunk (not in
Firefox 2.0.0.12 or Camino 1.5.5), and only as of the
firefox-2007-03-27-04-trunk nightly.

This regression range makes it very likely that the patch for bug
344427 ("Implement CoreGraphics NPAPI Drawing Model") is what caused
(or triggered) the problem.

(Later I'll also test on OS X 10.4.11.)
Status: UNCONFIRMED → NEW
Component: Plugin Finder Service → Plug-ins
Ever confirmed: true
Product: Firefox → Core
Version: unspecified → Trunk
Oops, wrong bug :-(

I'll probably get to this one on the weekend.
Using Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9b5pre) Gecko/2008031304 Minefield/3.0b5pre, I get the same error in the console reported in Comment 0. The only intermediary step that is missing is that I get a dialog asking me to "Trust" the signed applet, which I did. When I reach the login page if I click the "Browse" button nothing happens and I get the error.
I don't know why I did not get the intermediary step about the "trust" applet.  I don't know whether it's because I was able to successfully get to the site and click the browse button without errors under Safari?
QA Contact: plugin.finder → plugins
Just as a point of information, when I launch this same site on the Windows XP nightly, I get a dialog indicating the digital signature has been verified.
This is a dup of bug 421855.	

The following message appears many times in the console log:

MRJ Plugin JEP: JavaScript-to-Java LiveConnect failed -- no security manager!
Status: NEW → RESOLVED
Closed: 14 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 421855
You need to log in before you can comment on or make changes to this bug.