Search 'Suggestions' appear left of window when Search box out of screen

RESOLVED WORKSFORME

Status

()

Firefox
Search
--
minor
RESOLVED WORKSFORME
10 years ago
8 years ago

People

(Reporter: Laurent G., Unassigned)

Tracking

3.0 Branch
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b4) Gecko/2008030714 Firefox/3.0b4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b4) Gecko/2008030714 Firefox/3.0b4

When the FF window is dragged to the right of the screen, hiding the right part of the search box (the magnifying glass is at least partially hidden), if you type letters in the box, the suggestions window appears to the left (about 70 pixels) of the FF window _out_ of the window (instead of inside the window with the right of the box aligned with the right of the screen as expected). In the worst case, your window is still large enough (less than 70 pixels from the left border of the screen), the suggestion box can disappear to the left of the screen.



Reproducible: Always

Steps to Reproduce:
1. start FF windowed, move the window to the right of the screen until the magnifying glass is at least partially hidden
2. type letters in the search box

Actual Results:  
The suggestion box appears about 70 pixels left of your FF window (outside of the window).


Expected Results:  
The suggestion box should have appeared under the search box with it's right border close or touching the right border of the screen.


I tried the opposite: moving the Search box to the left, then moving FF to the left until the Search box disapperas. In this case, the suggestion appears to the left of the screen, inside the FF window (as expected).
I'm able to reproduce this on a relatively recent nightly.
Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9pre) Gecko/2008052004 Minefield/3.0pre
OS: Windows XP → All
Version: unspecified → Trunk
I was able to confirm this on XP (RC1) and also on OSX (RC2).  It didn't seem to happen on Vista (beta4).

My theory is that it's related to multiple monitors and happens after disconnecting a monitor.  At least in the 2 cases I could confirm, it was due to a monitor being disconnected.  More testing would be required to confirm if that's the cause.  After rebooting, it appeared to work as expected.

Laurent, could you confirm that theory or is the case different for you?  If so the summary of this bug will need to be changed to reflect the exact case it happens.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Version: Trunk → 3.0 Branch
(Reporter)

Comment 3

10 years ago
(In reply to comment #2)
> My theory is that it's related to multiple monitors and happens after
> disconnecting a monitor. 
> Laurent, could you confirm that theory or is the case different for you?

Sorry, but the computer I used only has one monitor. As far as I know, it has never been connected in a multiple screens configuration. The video card does not even give the option (Intel 82865G, 96Mb, only one physical port).

I've a HARD time reproducing the issue. I still have not been able to pinpoint the origin of the problem (despite numerous tests), one thing is sure, it is not just a matter of starting the browser, you need something else...

For instance, I noticed that after _some_ time, the pb would be triggered. I tried to make the same visits on a fresh start, to no avail. I waited a while during some sessions, to no avail, then suddenly the pb appeared again. I have another hypothesis on some kind of pages (forms or long pages, etc.) 

Please note that once the pb is triggered, it will always be reproduced, no matter if you close all the tabs, etc.

Of course, I've checked both with addons and on a fresh profile. I was able to get the problem on both at least once.

Currently, I'm still trying to validate which combination of sites/time/tabs/whatever triggers it. I've already done a lot of tests, but the condition is still eluding me. I'll keep searching.

Comment 4

10 years ago
I can confirm this on my laptop:
- Dell XPS M1210 running WS2003 R2 Enterprise x64
Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0

However, I can't reproduce it on my Mac:
- Mac Mini running Mac OS X Leopard
Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9pre)
Gecko/2008061004 Minefield/3.0

Just FYI: On my Mac, FF prompted me to update just this afternoon, which I did. I don't recall if I have ever observed this on older versions of FF on Mac.

FF says I'm up to date on my laptop.

Hope this helps.

Comment 5

10 years ago
(In reply to comment #4)
> Just FYI: On my Mac, FF prompted me to update just this afternoon, which I did.
> I don't recall if I have ever observed this on older versions of FF on Mac.

I mean to say: I don't recall if I have ever observed this "bug" on older versions of FF on Mac.

Comment 6

10 years ago
Created attachment 325227 [details]
Misplaced suggestion box, even with the magnifying class still visible

An instance of this bug with the magnifying glass still visible on the screen.
I think this has something to do with my video player's "Always on top" feature.
Duplicate of this bug: 442253

Comment 8

10 years ago
I could reproduce this on my WinXP SP2 desktop with Firefox 3.0.1, but not on my Windows Vista laptop (v3.0.1).  The desktop has a single monitor, never in a dual setup.  The only difference is that Firefox on my laptop doesn't have any addons, so maybe that's the reason.  Addons on my desktop Firefox (to see if we have any common): Adblock Plus, BugMeNot, FlashGot, Free Download Manager plugin, Greasemoney and IE View.  I use the default theme on both.  Another difference is that Vista's theme is the default (Aero or whatever), but my XP is using Classic, so it looks like Windows 2000.  Not sure if that matters.

However, a similar situation (which prompted me to look into this bug) which I can reproduce on both desktop and laptop is if I keep the search field visible but down to the bottom of the screen, the Google Suggest results will cover the search field as they make a list going up.  Probably a similar root issue where the start of the list isn't set correctly.

Comment 9

9 years ago
I can confirm this on my laptop (Dell Studio S15) running vista and firefox 3.5.2

Comment 10

8 years ago
WFM ff 3.6.8
i remember it not working at one point
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.